Home > GNU/Linux, Guide pratiche GNU/Linux > Firefox 3.5.3, per bene, con l’antialiasing, su Ubuntu

Firefox 3.5.3, per bene, con l’antialiasing, su Ubuntu

QUESTA GUIDA E’ STATA AGGIORNATA PER FIREFOX 3.5.3

Personalmente sono un maniaco della perfezione ed oggi, installando Firefox 3.5, mi sono accorto che l’antialiasing non faceva il suo dovere. Inoltre non volevo perdere l’estensione ubufox (Ubuntu Firefox Modification) che permette di scegliere quale plugin utilizzare mentre si vede un filmato.

Ecco una semplice guida per risolvere il tutto e usare Firefox 3.5.3 senza nessun rimpianto.

1. Prima di tutto salvatevi i preferiti di Firefox in formato json (segnalibri > organizza segnalibri > importa e salva > salva)

2. ATTENZIONE:  Firefox 3.5.3 è ora nei repository ufficiali di Ubuntu Jaunty, potete saltare questo passaggio e andare subito al punto 3 se avete questa versione, altrimenti se avete ancora Hardy o Intrepid è necessaria.

Ora aggiungiamo il repository tramite “sorgenti software”

deb http://ppa.launchpad.net/fta/ppa/ubuntu hardy main

Se usate Ubuntu  Intrepid (8.10) dovete sostituire la parola  hardy con intrepid, rispettivamente. Una volta fatto  fate ricaricare la lista. Poi da terminale importiamo la chiave:

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0C713DA6

3. Da Synaptic installiamo:

  • firefox-3.5
  • firefox-3.5-branding
  • firefox-3.5-gnome-support
  • xulrunner-1.9.1
  • xulrunner-1.9.1-gnome-support

Gli ultimi due vengono selezionati automaticamente, comunque controllate.

4. Ora avete installato “shiretoko”, ma è Firefox 3.5.3, tranquilli.

5. Adesso da Synaptic disinstallare ubufox.

Aprite Shiretoko e scaricate questo: http://www.megaupload.com/?d=AUTK0QF6

6. Salvatelo e poi trascinatelo nella finestra di Shiretoko. Riavviate come vi viene chiesto.

7. Ora occupiamoci della lingua, se non è in italiano allora: http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5.3/win32/xpi/it.xpi, salvatelo e trascinatelo nella finestra (in realtà firefox/shiretoko dovrebbe chiedervi di installare direttamente il pacchetto).
EDIT (19 luglio): Al momento i repository per Hardy e Intrepid non contengono Firefox 3.5.2 ma ancora Firefox 3.5 per cui il pacchetto della lingua da installare è questo.

8. Bene, adesso passiamo ai caratteri. Date questi comandi da terminale:

cd /etc/fonts/
sudo mv conf.d/10-hinting-slight.conf .
sudo ln -s conf.avail/10-hinting-slight.conf conf.d/
sudo mv conf.d/10-hinting.conf .
sudo ln -s conf.avail/10-hinting.conf conf.d/
sudo dpkg-reconfigure fontconfig

Riavviate la sessione per sicurezza e quindi avviate Shiretoko.

9. Ultimi aggiustamenti:

  • importate i segnalibri precedentemente salvati
  • scrivete about:config su Shiretoko, scrivete “useragent”. Nella chiave “general.useragent.extra.firefox” cambiate e mettete Firefox/3.5.3
  • aggiungere il motore di ricerca Google italia da qui: http://mycroft.mozdev.org/google-search-plugins.html

10. Cambiamo l’icona di Shiretoko con quella di Firefox:

sudo cp /usr/lib/firefox-3.0.14/chrome/icons/default/default* /usr/lib/firefox-3.5.3/chrome/icons/default
sudo cp /usr/lib/xulrunner-1.9.0.14/icons/mozicon* /usr/lib/xulrunner-1.9.1.3/icons/
sudo cp /usr/lib/firefox-3.0.14/icons/mozicon* /usr/lib/firefox-3.5.3/icons/

EDIT (19 luglio): Nel caso di Firefox 3.5 invece che 3.5.3 (utenti che hanno ancora Hardy e hanno aggiunto i repository “fta”) modificate il percorso di destinazione dei comandi precedenti mettendo firefox-3.5 al posto di firefox-3.5.3.

11. Ora se tutto va bene, non ci resta che eliminare il link al vecchio Firefox e metterlo a quello nuovo:

sudo su
cd /usr/bin
rm firefox
ln -s firefox-3.5 firefox

Finito ;)

Il browser va molto bene e mi libera finalmente la memoria… adesso occupa meno della metà di quanto mi occupava Firefox 3.0.11.

EDIT: se Flash vi crasha a schermo intero (capita con le schede nvidia), procedete così:

gedit firefox.sh

scrivete:

LD_PRELOAD=/usr/lib/libGL.so.1 firefox-3.5

salvate e date i permessi di esecuzione:

chmod +x firefox.sh

Ora modificate il menu (sistema > preferenze > menu principale) cercate l’icona di firefox e modificate il comando di lancio mettendo:

/home/numeutente/firefox.sh

Baci e abbracci.
Serve aiuto? LQH!

About these ads
  1. 1 luglio 2009 alle 21:10

    Puoi creare uno screenshot che renda l’idea di come l’antialiasing ha migliorato la tua esperienza?

    • 2 luglio 2009 alle 10:12

      be’ con l’antialiasing è identico a com’era FF3.0

  2. Paguro
    1 luglio 2009 alle 23:06

    Scusa Guiodic, ma FF3.5 non lo riceveremo tramite aggiornamento su Ubuntu 9.04?

    • 2 luglio 2009 alle 10:11

      No.

      • Paguro
        2 luglio 2009 alle 14:10

        Grazie per la guida, ho installato tutto senza problemi, mi aiuteresti a mettere Google in italiano come motore di ricerca predefinito, di base mi trovo Ask.com, vorrei cambiarlo con Google in italiano.
        Un altra cosa, se disinstallo il repository dal quale ho installato firefox 3.5, firefox 3.5 sarà aggiornato ugualmente?

      • 2 luglio 2009 alle 18:30

        ho modificato il repository, questo dovrebbe contenere anche i prossimi aggiornamenti di FF 3.5

  3. Irene
    2 luglio 2009 alle 0:09

    Grazie mille : )

  4. Silente0965
    2 luglio 2009 alle 9:25

    Ottima guida….sei fortunato per la ram,perchè a me occupa esattamente il doppio della versione precedente…l’ho dovuto levare dopo un’ora di utilizzo.

    • 2 luglio 2009 alle 10:12

      strano… non è che è colpa di qualche estensione?

  5. 2 luglio 2009 alle 10:29

    Ciao, grazie per la guida. Avrei un paio di domande da fare:
    1) Dopo l’installazione bisogna rimuovere il repository PPA?
    2) Cosa succede in caso di aggiornamenti del ramo “ufficiale” di Firefox (3.0.X)?

    • 2 luglio 2009 alle 10:37

      1) sì, assolutamente sì. Quel ppa che ho segnalato aggiorna pure pulseaudio e altre cose, è sconsigliabile.
      2) dovrebbe, ma non sono sicuro, essere cancellato il link firefox->firefox-3.5 in tal caso va ripristinato.

    • 2 luglio 2009 alle 18:31

      ho modificato il repository, questo dovrebbe contenere anche i successivi aggiornamenti e non ha problemi con altri pacchetti.

  6. nicotto
    2 luglio 2009 alle 10:33

    Intanto grazie per la guida,
    senti, mi dà problemi di autenticazione del repository, mica c’è una chiave da aggiungere?

    • 2 luglio 2009 alle 10:38

      fregatene, tanto devi installare solo quei pacchetti e poi togliere il repository.

  7. nicotto
    2 luglio 2009 alle 10:53

    Ok…installato con successo, anche se non mi sarebbe dispiaciuto avere la nuova icona di firefox. L’ho anche impostata come immagine per il collegamento nel menu. Mica si può cambiare anche l’icona in alto a sinistra nella finestra.

    • 2 luglio 2009 alle 11:50

      Ho aggiunto alla guida anche questo ;)

      • 2 luglio 2009 alle 15:30

        Non è vero, tu copi le icone della 3.0.11. Logo ed icone sono cambiati in Firefox 3.5! ;)

  8. Shishimaru
    2 luglio 2009 alle 12:02

    ma come mai shirekoto? non è normale… mettendo firefox 3.5 preso direttamente dal sito mozilla esce firefox 3.5 come dovrebbe essere… peccato che non si può installare come si deve come con i .deb!
    ti ringrazio per l’ottima guida!!

    • 2 luglio 2009 alle 18:32

      Perché se ti compili a mano Firefox lo chiama Schiretoko.

  9. Win90
    2 luglio 2009 alle 14:37

    Ma dimmi te se mi devo fare tutto sto sbatti per aggiornare Firefox. Ecco perchè GNU/Linux lo usano solo i nerd. Tutte ste paranoie sulla sicurezza e manie di perfezione in quanto riguarda le prestazioni e poi bisogna farsi uno sbattone per aggiornare Firefox quando su win compare la notifica, premi ok ed il gioco è fatto.

    Buon divertimento pinguini.

    • 2 luglio 2009 alle 16:09

      Se è per questo si può anche scaricare il pacchetto dal sito… semplice semplice, senza fare nulla.

    • Deckard
      2 luglio 2009 alle 23:44

      Asd Win90, per favore, prima di esultare false vittorie informati va… ;)

      • aytin
        3 luglio 2009 alle 11:08

        Ma non te la prendere, suvvia.
        Cosa vuoi che capisca chi va in sbattimento solo se gli cambi la disposizione delle icone sul desktop?
        La flessibilità non è di questo mondo (del loro), come pure la capacità di contenersi nell’emettere giudizi sfinterici.

    • Shishimaru
      4 luglio 2009 alle 21:11

      da quando in qua su win per passare a una nuova major release basta un click? ma va là…

      • 6 luglio 2009 alle 9:44

        Forse non hai provato… in effetti basta un click su “cerca aggiornamenti” e ti scarica la nuova 3.5.
        Non capisco perché non si possa avere, almeno per Jaunty, un bel *.deb tuttofare.
        Linux for Human Beings…

        • 6 luglio 2009 alle 10:31

          Ma è nei repository proposed, che problema c’è?

    • 7 luglio 2009 alle 11:33

      @Win90
      Infatti basta semplicemente scaricare il pacchetto dal sito ufficiale di Firefox, scompattarlo e funziona immediatamente. Non vedo la grande difficoltà di farlo funzionare su Linux.
      Io utilizzo Firefox 3.5 insieme a Firefox 3.0.11 e non ho nessun problema.

    • 9 agosto 2009 alle 15:11

      Win90, svegliati, non sai neanche cos’è un code-freeze…

  10. 2 luglio 2009 alle 15:53

    @guiodic

    non è più semplice scaricare la versione linux in italiano da

    http://www.mozilla-europe.org/it/

    , magari solo modificando provvisoriamente il lanciatore?

    Così si evita di toccare i file di sistema (hai detto ‘maniaco della perfezione’?), è puoi installare allo stesso modo ubufox, un aio di dizionari e sei apposto.

    • 2 luglio 2009 alle 16:11

      A quanto so quella versione non è compilata per il supporto dell’antialiasing, comunque io preferisco usare sempre i pacchetti deb.

      • Paguro
        2 luglio 2009 alle 17:06

        ho installato tutto senza problemi, mi aiuteresti a mettere Google in italiano come motore di ricerca predefinito, di base mi trovo Ask.com, vorrei cambiarlo con Google in italiano.
        Un altra cosa, se disinstallo il repository dal quale ho installato firefox 3.5, firefox 3.5 sarà aggiornato ugualmente?

  11. 2 luglio 2009 alle 17:50

    no, non verrà aggiornato automaticamente.
    quanto a google, basta che clicchi sulla freccetta nell’area di ricerca.

  12. Daniele
    2 luglio 2009 alle 18:10

    ciao,complimenti per la guida ,io ho un piccolo problema,non riesco a trasformare shiretoko in italiano.

    • 2 luglio 2009 alle 18:32

      hai scaricato il pacchetto per l’italiano come è spiegato nella guida?

  13. testadilegno
    2 luglio 2009 alle 19:21

    Ciao, ottima guida, ma prima di provare ti volevo chiedere: vale anche per le architetture a 64 bit?

  14. Scugnizzo
    2 luglio 2009 alle 19:54

    Miiii ci sono rimasto malissimo!!
    Ma come?….torno a casa…..lancio l’aggiornamento della mia Jaunty e niente firefox 3.5….poi scopro che non verrà messo nei repo “normali”.
    Mi domando….perchè mai avranno deciso di non inviarci questo aggiornamento??

    • 2 luglio 2009 alle 20:17

      La politica di Ubuntu è di non aggiornare finché non esce un’altra release. Comunque è possibile che quando Mozilla toglierà il supporto a Firefox 3.0.x allora venga aggiornato, non prima.

  15. testadilegno
    2 luglio 2009 alle 21:09

    …e per i 64bit?

  16. 2 luglio 2009 alle 21:16

    è lo stesso.

    • testadilegno
      2 luglio 2009 alle 21:26

      Ok, grazie!

  17. cristiano
    2 luglio 2009 alle 22:27

    il link a megaupload non funzia

    • 2 luglio 2009 alle 23:02

      l’ho appena fatto e funzia.

      • Giovanni
        2 luglio 2009 alle 23:54

        No, davvero, non funziona.

        • 3 luglio 2009 alle 2:25

          l’ho rifatto di nuovo e funziona…

          • Giovanni
            3 luglio 2009 alle 12:13

            A me continua a non funzionare.

  18. SxEdge
    2 luglio 2009 alle 23:36

    Se proprio volete le nuove icone di firefox potete prenderle da qui

    http://blog.mozilla.com/faaborg/2009/06/18/the-new-firefox-icon/

    e copiare quelle delle dimensioni corrette su /usr/lib/firefox-3.5/chrome/icons/default

  19. SimonMago
    3 luglio 2009 alle 11:19

    Dando: sudo cp /usr/lib/xulrunner-1.9.0.11/icons/mozicon* /usr/lib/xulrunner-1.9.1/icons/

    Mi da: cp: l’obiettivo “/usr/lib/xulrunner-1.9.1/icons/” non è una directory

    Che devo fare?

    • 3 luglio 2009 alle 19:08

      Il comando è corretto, l’ho appena provato.

      • SimonMago
        4 luglio 2009 alle 11:29

        Ok, non mettevo in dubbio che fosse giusto…
        …Ma a me da quella risposta…
        Sai cosa può essere?
        ADBLOCK era installato dalla pagina di firefox.
        Cmq or aprovo a disinstallarlo e reinstallaralo come dici tu.
        Xò ho notato che la skin che utilizzo, che non è compatibile con la 3.5, sulla versione che ho installato seguendo le tue indicazioni c’è…
        Non è strano?

  20. SimonMago
    3 luglio 2009 alle 11:31

    Altra cosa, mi dice che adblock non è compatibile con firefox 3.5, ma in realtà lo è…
    Anche per la versione 3.5 ufficiale.

    • 3 luglio 2009 alle 19:07

      devi aggiornare adblock. se lo hai installato da repository devi disinstallarlo e installare quello dal sito degli addon di mozilla.

      • SimonMago
        4 luglio 2009 alle 19:08

        Allora Dando: sudo cp /usr/lib/xulrunner-1.9.0.11/icons/mozicon* /usr/lib/xulrunner-1.9.1/icons/

        Continua a darmi: cp: l’obiettivo “/usr/lib/xulrunner-1.9.1/icons/” non è una directory

        Cmq, sembra andare, per adblock ho fatto come avevi detto: ho disinstallato da synaptic e l’ho reinstallato dalla pagina dei componenti aggiuntivi e ora c’è.
        Xò mi da un’altro problema, se disinstallo un programma e clicco su riavvia, la pagina mi si chiude, ma non si riapre +…
        Se invece installo un programma e faccio la medesima cosa, si riavvia.
        Altra piccolezza, nella ricerca automatica nella barra degli indirizzi mi escono le scritte in blu…

        • 4 luglio 2009 alle 19:28

          non ho capito nulla.

          • SimonMago
            4 luglio 2009 alle 20:25

            Scusa… ^^

            Allora, digitando da terminale: sudo cp /usr/lib/xulrunner-1.9.0.11/icons/mozicon* /usr/lib/xulrunner-1.9.1/icons/

            La risposta è: cp: l’obiettivo “/usr/lib/xulrunner-1.9.1/icons/” non è una directory

            (come detto in precedenza)

            Però, tutti gli altri comandi non mi danno problemi.
            Infatti firefox sembra funzionare abbastanza bene (è davvero + leggero e veloce).

            Adblock reinstallandolo da synaptic e reinstallandolo dalla pagina dei componenti aggiuntivi (come mi avevi consigliato) funziona.

            Problemino: capita che se installo-disinstallo qualche plugin e clicco su riavvia, firefox si chiude e non si riavvia +.

  21. streetcross
    3 luglio 2009 alle 14:07

    Scusa Guiodic ma questi pacchetti nei repo ufficiali non forniscono già FF 3.5? http://packages.ubuntu.com/search?keywords=firefox&searchon=names&suite=jaunty&section=all
    Lo chiedo a te perchè li ho visti per caso ma non ho voglia di installare FF3.5 da repo dopo che me lo sono compilato e mi gira più svelto!

  22. streetcross
    3 luglio 2009 alle 14:50

    Ok come non detto, sono alla beta4 nei repo jaunty :D

  23. Jay
    3 luglio 2009 alle 16:21

    Ciao e grazie mille di questa guida. Ho un piccolo dubbio: firefox 3.0.x? possiamo cancellarlo??

  24. 3 luglio 2009 alle 17:00

    Qualcuno ha notizie su come installare Firefox 3.5 su hardy?!

    • 3 luglio 2009 alle 19:03

      è uguale, nel repository che ho messo adesso ci sono anche i pacchetti per hardy

  25. Sose
    3 luglio 2009 alle 18:54

    Ciao
    Dopo aver scaricato il pacchetto per la lingua “italiano” mi dice che non è compatibile come mai?

  26. ronin117
    3 luglio 2009 alle 20:17

    ciao guiodic, complimenti per la guida.
    Ho appena letto che a metà luglio ci sarà il primo aggiornamento della 3.5 che passerà alla 3.5.1. In che modo si potrà aggiornare?
    Nuova reinstallazione?

    • 3 luglio 2009 alle 20:56

      dovrebbe essere messa nei repository che hai aggiunto, quindi non dovresti fare nulla, ti verrà segnalato l’aggiornamento entro 24-48 ore.

  27. Jay
    3 luglio 2009 alle 21:56

    Nessuno mi risponde? Lo so è una domanda stupida però per essere sicuro…

    • 3 luglio 2009 alle 22:01

      se provi a disinstallarlo va via sun-java6-plugin, poi magari java non ti funziona nel browser.

  28. Scugnizzo
    3 luglio 2009 alle 22:30

    Guido scusa, ma attivando i proposed mi propone un nel pò di aggiornamenti (circa 70 Mb) ma non FF 3.5.
    Sbaglio forse qualcosa?
    Ma poi….secondo voi…questi 70 mb di aggiornamenti possono servire? (pulse, lib mesa, jdk etc)

    • 3 luglio 2009 alle 22:36

      se non sei esperto non fare aggiornamenti, installa i pacchetti che ho indicato e poi disattiva i proposed.

  29. 4 luglio 2009 alle 2:00

    Ciao a tutti!
    Ho riscontrato il seguente problema con la nuova versione di Firefox 3.5.1pre. Allego i link alle immagini per spiegare il problema, diversamente non è spiegabile.

    Spero qualcuno sappia aiutarmi. Forse è questo il problema di anti-aliasing di cui si parla???

    Grazie a chiunque mi sappia aiutare.

    • 4 luglio 2009 alle 12:43

      Ho trovato la soluzione al problema delle immagini con colori totalmente sfasati.
      Firefox 3.5.1pre evidentemente usa la correzione dei colori per le immagini, questo fa si che le immagini vengano visualizzate con colori sfasati.
      Per quelli che come me hanno incontrato questo genere di problema la soluzione è andare a modificare la chiave gfx.color_management.mode nelle configurazioni di firefox.
      Per modificare il valore di gfx.color_management.mode scrivete nella barra degli indirizzi about:config e poi cercate la chiave indicata, fate doppio click e modificate il valore a 0.

      Buona visione a tutti.

  30. aletux
    4 luglio 2009 alle 2:25

    grazie per la guida tutto perfetto.

  31. Scugnizzo
    4 luglio 2009 alle 16:36

    Perfetto! Tutto installato dai proposed e funzionante.
    Peccato che ho avuto la brillante idea di disinstallare contestualmente FF 3.0 e mi son perso l’icona. Ma è irrilevante.
    Grazie Guido.

    p.s. Sul portatile ho aggiornato tutto dai proposed e sembra funzionare tutto (sembra..nel caso vi farò sapere)

  32. 4 luglio 2009 alle 17:40

    Ciao, Sto provando a installare FF su Hardy. Ho inserito il repo, ma quando cerco di installare FF da Synaptic, mi esce questo errore:
    xulrunner-1.9.1:
    Dipende: libasound2 (>1.0.18) ma 1.0.15-3ubuntu4 verrà installato
    Dipende: libdbus-glib-1-2 (>=0.78) ma 0.76-1ubuntu1~nm1~hardy1 verrà installato
    Dipende: libgtk2.0-0 (>=2.16.0) ma 2.12.9-3ubuntu5 verrà installato
    Dipende: libhunspell-1.2-0 (>=1.2.4) but it is not installable
    Dipende: libnspr4-0d (>=4.7.3-0ubuntu1~) ma 4.7.1+1.9-0ubuntu0.8.04.5 verrà installato
    Dipende: libnss3-1d (>=3.12.2~rc1) ma 3.12.0.3-0ubuntu0.8.04.5 verrà installato
    Dipende: libpython2.6 (>=2.6) but it is not installable
    Dipende: libsqlite3-0 (>=3.6.10) ma 3.4.2-2 verrà installato

    Cosa fare…?

    • 4 luglio 2009 alle 17:50

      ovviamente non hai cambiato jaunty con hardy.

  33. 4 luglio 2009 alle 17:54

    Ovviamente…!
    Grazie!!!

  34. Scugnizzo
    4 luglio 2009 alle 20:20

    Risalve,
    piccolo problema.
    In thunderbird se clicco su un collegamente, sia esso in una email o nella pagina di un blog non mi apriva il collegamento in FF 3.5.
    Ho impostato in “Applicazioni preferite” il browser web come comando personalizato “firefox-3.5 %u” ed ora il browser si apre ma non sulla pagina del collegamento ma su “http://%u/”.
    Provando ad eliminare la “u” dal comando mi si apre soltanto “http://%/”.
    Sbaglio io qualcosa o qualcosa non va?

    • obo
      5 luglio 2009 alle 10:33

      prova a mettere firefox-3.5 %s

    • 5 luglio 2009 alle 10:51

      basta che cancelli il link e crei il nuovo link come destritto nella guida, poi rimetti firefox come predefinito.

      • Scugnizzo
        5 luglio 2009 alle 11:29

        Perfetto!
        Mettendo la “s” (come del resto è per thunderbird in basso alla finestra) funziona benissimo!
        Grazie ragazzi.

  35. Jacopo Rubino
    5 luglio 2009 alle 13:05

    grazie per la guida. non capisco però come si possa rimuovere la versione 3.0.11. qualcuno può aiutarmi?

    • 5 luglio 2009 alle 13:33

      non la rimuovere, che problema ti dà?

      • Jacopo Rubino
        5 luglio 2009 alle 13:45

        ho installato la 3.5 per sostituire la vecchia versione. sul mio portatile avevo rimosso la 3.0 da synaptic ma, non so come mai, è ritornata con le impostazioni di base.

  36. Jay
    5 luglio 2009 alle 13:07

    Sto riscontrando un problema piuttosto strano…alcune immagini non si caricano. Soprattutto le immagini anti-spam che mostrano quelle lettere da inserire per inviare un messaggio o scaricare qualcosa…qualcuno di voi ha avuto lo stesso problema?

  37. gyanny
    5 luglio 2009 alle 17:35

    io ho installato firefox 3.5 dando da terminale
    sudo apt-get install firefox-3.5
    senza attivare i proposed.
    unico inconveniente che m’ha tirato dietro synaptic e altra roba di gnome che mi son dovuto poi rimuovere perchè uso KDE.
    vuol dire che è stato pubblicato nei repo ufficiali?

    • 6 luglio 2009 alle 0:42

      se non hai attivato i proposed allora hai installato la versione beta 4

  38. DjNeophyte
    6 luglio 2009 alle 22:20

    Installato su jaunty con kde4.3rc1 , abilitato il plugin konquefox per dare una regolatina all’aspetto e il risultato e’ piu’ che soddisfacente,unica pecca e’ la marea di dipendenze che si tira dietro,ma la cosa non da fastidio.

    • 6 luglio 2009 alle 23:05

      c’è il modo di installarlo senza dipendenze raccomandate, basta dare:

      sudo apt-get install firefox-3.5 –no-install-recommends

      e ovviamente non installare gnome-support.

  39. Alessandro Nciolai
    7 luglio 2009 alle 14:21

    Ciao a tutti.. ho seguito in maniera pedissequa la guida ma ho riscontrato alcue anomalie..

    Anzitutto firefox mi rileva delle incompatibilità con i pacchetti:

    Firefox (en-GB) 3.0.7
    Firefox (it) 3.0.7
    Xulrunner (en.GB) 1.9.0.8
    Xulrunner (it) 1.9.0.8

    Ciononostante io abbia installato le versione indicate nel post!!

    Un’altra cosa che non capisco è che dopo aver aggiunto lingue e caratteri su firefox, mi ha modificato i caratteri di Amsn… è un bug!?

    Ultimissima cosa mi chiedo, come mai a livello di synaptic, firefox 3.0 risulta ancora installato? va bene o devo toglierlo?

    Grazie a tutti

    • 7 luglio 2009 alle 18:28

      è tutto normale. Quei pacchetti sono le lingue del vecchio firefox che ovviamente non vengono attivate dal 3.5

      firefox 3.0 se vuoi puoi toglierlo ma meglio tenerlo secondo me.

      • Alessandro Nciolai
        7 luglio 2009 alle 22:28

        sei gentilissimo a rispondere… ti ringrazio veramente di cuore!

        Piuttosto dici che sia un bug il cambiamento di caratteri su Amsn?

  40. nakki
    7 luglio 2009 alle 15:13

    Ho installato firefox 3.5 dai repo senza attivare i proposed, sembra la versione finale…
    Ho seguito la guida per i caratteri, per le icone e sull’about:config ma c’è una cosa strana: quando vado a chiudere firefox con più schede aperte, mi appare come sempre la finestrina per poter salvare le schede aperte, nulla di strano, ma oltre alla finestra sento il suono che fa ubuntu all’avvio del gdm (i tamburelli)….cosa alquanto strana….capita a qualcun’altro??

    • 7 luglio 2009 alle 18:29

      sì, è normale.

      • nakki
        7 luglio 2009 alle 20:11

        Non c’è il modo di levarlo?

        • 7 luglio 2009 alle 20:29

          non lo so, io l’avviso l’ho proprio tolto.

  41. 7 luglio 2009 alle 15:34

    Ciao,
    ho seguito la tua guida, ti dirò che inizialmente, data la mia scarsa conoscenza in ambito linux (mi sto cimentando per conoscere meglio le basi) ho fatto un po’ di fatica. Ora però ho Firefox 3.5 in italiano. Se vado su “Aiuto” e “Informazioni su Mozilla Firefox” mi dice che la versione è la 3.5.1pre.
    Comunque il mio problema è un altro: non salva la cronologia né i preferiti, e non riesco a importarli anche se esportati in html.
    Se invece faccio sudo firefox-3.5 mi si apre Firefox 3.5 in italiano, con la cronologia e i preferiti.
    Talvolta quando lo apro senza usare root mi appare la fascia rossa che dice che non riesce a caricare cronologia e preferiti… non capisco, perdona la mia ignoranza…
    Grazie!

    • 7 luglio 2009 alle 18:30

      non hai seguito la mia guida, perché se l’avessi fatto avresti il 3.5 non il 3.5.1.
      Invece tu hai aggiunto i repository mozilla-daily.

  42. 8 luglio 2009 alle 0:01

    Ok, ora mi dice “Versione 3.5″. E’ in italiano.
    Il problema rimangono i preferiti e la cronologia, e vengo avvertito con questa fascia rossa che rimanda a questo link:

    http://support.mozilla.com/it/kb/The+bookmarks+and+history+system+will+not+be+functional?style_mode=inproduct

    E’ perchè non ho fatto il backup del profilo?

  43. 8 luglio 2009 alle 0:17

    Ho risolto, grazie!
    Il problema erano i profili.
    Ciao!

  44. teimcrr
    8 luglio 2009 alle 14:25

    Scusa guiodic,
    ma se installo la versione da sito Mozilla, posso poi attivare l’antialiasing con i comandi di cui la punto 8 della tua procedura ?

    Ciao.

    • 8 luglio 2009 alle 14:35

      La build ufficiale di Mozilla non è compilata con libcairo.
      Ho provato a scaricare la build dal sito di Mozilla dopo aver fatto la modifica per i caratteri.
      Il risultato non è pessimo, ma su un monitor LCD la differenza si nota, i caratteri appaiono leggermente seghettati.

  45. zeruel85
    9 luglio 2009 alle 15:19

    ciao guiodic, io sono arrivato al passo 5 ed ho disinstallato con successo ubufox. però quando lancio shiretoko crasha il programma. allora l’ho lanciato da terminale per vedere che errore dava. te lo riporto:

    Error: in (function call): procedure or syntax required but got: Error: fatal: looped fatal error

    uso hardy i386 su un dell inspiron 6400 per la cronaca.

    • 9 luglio 2009 alle 22:56

      hai usato i repository per Hardy, giusto?

      • zeruel85
        9 luglio 2009 alle 23:22

        sì.

        per curiosità ho provato anche a scaricare direttamente dal sito della mozilla il tar.bz2, ma anche con quello mi dà lo stesso identico errore, quando lancio il programma.

        • 10 luglio 2009 alle 0:16

          prova con

          firefox-3.5 -safe-mode

          se parte vuoi dire che hai qualche estensione che te lo fa crashare.

          • zeruel85
            10 luglio 2009 alle 9:35

            grazie, ho provato, ma continua a darmi sempre lo stesso maledetto errore.

  46. teimcrr
    9 luglio 2009 alle 16:14

    In realtà mi sembra che i comandi per l’antialiasing modifichino la resa dei caratteri per tutti gli utenti e per tutte le applicazioni, non solo Firefox.

    Sbaglio ?

  47. 10 luglio 2009 alle 9:56

    @zeruel85: ma ti dà solo questo da terminale?

    Forse è bene che apri un topic sul forum di Ubuntu, qui sul blog è un casino rispondere con i commenti :)

    • zeruel85
      10 luglio 2009 alle 11:48

      eh sì, solo quell’errore purtroppo, niente di più.

      grazie lo stesso per la disponibilità, proverò ad aprire un topic sul forum di ubuntu, appena ho un po’ di tempo libero. :)

      saluti!

  48. Claudio
    10 luglio 2009 alle 11:15

    Funziona tutto benissimo! Complimenti per la guida! L’unica cosa che invece ho notato è che a differenza della versione precedente non riesce a risolvere in automatico il proxy che è già impostato in preferenze>proxy di rete e devo impostarlo manualmente all’interno di firefox 3.5 Come mai? c’è la possibilità di fargli leggere i settaggi impostati in preferenze? Ciao e Grazie…

    • 10 luglio 2009 alle 12:34

      mmm… penso sia lo stesso problema che riguarda i caratteri: Firefox non legge le impostazioni di GNOME.
      La cosa più semplice è fare come hai fatto.

  49. Tufano Michele
    10 luglio 2009 alle 13:55

    Ciao Guiodic, prima di seguire la tua guida, avevo provato Firefox 3.5 tramite il tarball, scompattando ed eseguendo semplicemente Firefox 3.5. Avendo la curiosità di scoprire questo nuovo tag , mi ero connesso al sito Youtube HTML 5, tuttavia i video in esso presenti, non mi venivano visualizzati (solo schermata nera), mentre in un blog in cui si parlava di questa nuova funzione di HTML 5 riuscii a vedere un video taggato.

    Ho riprovato la stessa cosa con Firefox 3.5 installato correttamente attraverso al tua guida, ma identica cosa!

    E’ il sito a non rispettare gli standard?

    link: http://www.youtube.com/html5

    Ciao.

    • 10 luglio 2009 alle 15:14

      Quelli di google usano l’mp4 invece che l’ogg. Quei filmati li puoi vedere solo con safari.
      Comunque c’ una discussione accesissima proprio su questo fatto, le lobby hanno premuto per non stabilire che ogg è l’unico formato accettato.

  50. 15 luglio 2009 alle 23:47

    Ciao!
    Complimenti ottima guida!
    Purtroppo non riesco ad inserire nei motori di ricerca Google in italiano. Anche se premo la freccettina nella barra di ricerca non mi fa aggiungere il motore di ricerca “Google”

  51. 16 luglio 2009 alle 11:50

    Grazie sei un grande!

  52. marcellom
    18 luglio 2009 alle 9:49

    ciao ho seguito alla lettera la tua guida e ha funzionato. Adesso ubuntu mi ha proposto gli aggiornamenti alla versione 3.5.1 ed è diventato in inglese. Ho scaricato il file http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5.1/linux-i686/xpi/it.xpi ed è andato tutto a posto. La mia domanda è questa: tutte le volte che ci sarà un aggiornamento di firefox dovrò installare anche il pacchetto della lingua tutte le volte?

    Grazie mille

    • 18 luglio 2009 alle 11:04

      Prova a vedere se facendo l’aggiornamento dei plugin delle lingue ti prende quello nuovo.
      Altrimenti lo devi fare a “mano”.
      Purtroppo questo è un difetto di ubuntu ha ha messo il pacchetto per la lingua di FF dentro il pacchetto generale… prima era separato, si poteva aggiornare la lingua di FF senza toccare il resto.

  53. marcellom
    18 luglio 2009 alle 13:52

    ti faccio una domanda se aspettavo gli aggiornamenti di firefox senza seguire la tua guida avevo lo stesso problema?

  54. Jay
    18 luglio 2009 alle 16:49

    Perchè a me Ubuntu non propone la 3.5.1??

  55. cet
    18 luglio 2009 alle 18:27

    Ciao Guiodic,
    a me l’aggiornamento alla 3.5.1 oltre alla lingua ha ripristinato anche le icone di Shiretoko.

    • 18 luglio 2009 alle 18:57

      guarda la guida è stata aggiornata.

      • cet
        18 luglio 2009 alle 19:05

        scusami, non mi sono spiegato bene, quello che mi interessava sapere è se ad ogni aggiornamento bisognera ripristinare oltre alla lingua anche le icone. Poi un ultima cosa, ho notato che l’unica cosa che rimane di Shiretoko è l’icona delle Infomazioni su Mozilla Firefox. E’ possibile cambiarla?
        Grazie e davvero complimenti, la miglior guida per migrare a 3.5.
        Ciao

        • 18 luglio 2009 alle 19:30

          sì, anche la parte delle icone va ripetuta.
          Riguardo quella nelle info di FF non saprei dirti se è possibile cambiarla, per la verità no l’ho trovata.

  56. Doc
    19 luglio 2009 alle 19:27

    Ciao a tutti.
    Una domandina.
    Ho disinstallato FF3 e, naturalmente, se n’è andato via anche il sun-java6-plugin.
    Ora, se voglio rimetterlo, mi richiama FF3.

    Qualcuno sa se c’è un metodo alternativo per avere il java in FF3.5, senza dover rimettere FF3?

    Ciao e grazie!

    • 20 luglio 2009 alle 1:01

      prova così:

      sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so /usr/lib/firefox/plugins

      • Doc
        20 luglio 2009 alle 1:12

        Ho un sistema AMD64 e dunque non quella cartella

        • Doc
          20 luglio 2009 alle 1:16

          Anche dando sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so /usr/lib/firefox/plugins non va lo stesso.
          Grazie comunque.

          • 20 luglio 2009 alle 9:24

            se hai il 64 bit probabilmente usi icedtea plugin.
            controlla in synaptic.

          • Doc
            20 luglio 2009 alle 9:29

            Non ho né l’uno né l’altro, ma, a dirtela tutta, non ricordo nemmeno se ne avevo installato uno su Jaunty.
            Icedtea mi richiamerebbe l’openjava, che ho di recente rimosso (dopo anni di uso) in favore di quello ufficiale che, come riscontro, funziona meglio (programmi quali PDFSam, JDwonloader, etc.).

  57. Jay
    19 luglio 2009 alle 22:45

    Scusate ma io non ho capito come aggiornare al 3.5.1 :S qualcuno mi aiuta??

    • 20 luglio 2009 alle 0:57

      se hai installato il FF 3.5 allora l’aggiornamento dovrebbe avvenire in automatico.

      • Jay
        20 luglio 2009 alle 13:13

        Il bello è che non avviene :°D

        • 20 luglio 2009 alle 14:22

          controlla di avere attivi i repository universe multiverse.

  58. Frecciaazzurra
    20 luglio 2009 alle 7:04

    Salve ,
    Complimenti e grazie per la guida .
    il tutto é andato come da te spiegato , tranne informazione sulla versione da Aiuto/informazione su mozilla firefox .
    dopo essere entrato su ABOUT:CONFIG e modificando : general.useragent.extra.firefox cliccando col tasto destro del mouse e selezionando modifica , Cambio shirotoko 3.5.1 con firefox 3.5/ .
    mi dice sempre versione 3.5.1
    Mozilla Firefox for Ubuntu
    Canonical – 1.0
    dove sbaglio ?
    Saluti

  59. Frecciaazzurra
    20 luglio 2009 alle 13:55

    Ciao .
    Ma scusa perché dopo aver cambiato mi risulta Sempre 3.5.1 ?

  60. Frecciaazzurra
    20 luglio 2009 alle 14:39

    versione 3.5 no ?

  61. Frecciaazzurra
    20 luglio 2009 alle 14:43

    si tutti i repository sono attivati

  62. Giac
    20 luglio 2009 alle 15:49

    Grazie per la guida. Per me sono stati sufficienti i passaggi 3-7-10-11 (non uso ubufox e non ho visto problemi con l’antialias). Ora però mi chiedo… se volessi disinstallare i pacchetti di firefox 3.0 farei qualche danno?

    • 20 luglio 2009 alle 17:16

      Se li disinstalli se ne va sun-java6-plugin. Volendo si può evitare, ma avere un browser di emergenza non fa male.

  63. Doc
    20 luglio 2009 alle 21:59

    Ragazzi, ho trovato un modo per rimettere il plugin java SENZA RITROVARSI FF3.
    Trovate tutto in appendice a questa guidarella: http://forum.eeepc.it/viewtopic.php?pid=77594#p77594

    Un metodo un po’ contorto, ma va benissimo.

    @ guiodic
    Puoi anche, se vuoi, inglobare le mie indicazioni nella tua bellissima guida.
    Anzi, per me sarebbe un onore!

    Ciao e buon java!

  64. Jay
    20 luglio 2009 alle 23:32

    Ho controllato e ho sia gli universe che i multiuniverse attivati. Tuttavia ho provato ad attivare i proposed ma nulla, nessuna traccia di FF 3.5.1…cosa posso fare per risolvere il problema?

    • 21 luglio 2009 alle 0:20

      ma che versione hai di ubuntu?

      • Jay
        21 luglio 2009 alle 23:37

        Intrepid

        • 21 luglio 2009 alle 23:41

          Allora è normale, non hanno ancora messo la 3.5.1 nei repository di FTA.

          • Jay
            22 luglio 2009 alle 13:13

            Ah…quindi devo solo aspettare?

          • Jay
            22 luglio 2009 alle 19:45

            Sono appena arrivati gli aggiornamenti! Solo che quando avvio FF è sempre la 3.5 e non la 3.5.1 uhm….

          • Jay
            22 luglio 2009 alle 19:50

            Ah ora che ci penso c’era scritto Firefox 3.0…mi sa che erano aggiornamenti per la 3.0 e non la 3.5 XD sto facendo un macello :p

  65. Mithrandir
    23 luglio 2009 alle 16:02

    ciao, non so se ho capito tutto ma cercando di aprire il link http://www.megaupload.com/?d=AUTK0QF6 mi dice che non esiste più? che faccio?

    • 24 luglio 2009 alle 2:57

      strano, a me funziona perfettamente.

      Eventualmente puoi installare il pacchetto ubufox di karmic cercando in packages.ubuntu.com

  66. 23 luglio 2009 alle 17:10

    Ciao e grazie per la guida.

    Essendo Firefox 3.0 stato aggiornato alla versione 3.0.12 ti consiglio di aggiornare i comandi alla fine della guida per la sostituzione dell’icona e magari potresti rinominare il comando per lanciare firefox 3.0 invece di rimuoverlo.

  67. 23 luglio 2009 alle 18:17

    crash@crash:/etc/fonts$ sudo mv conf.d/10-hinting-slight.conf .
    mv: impossibile fare stat di `conf.d/10-hinting-slight.conf’: Nessun file o directory
    come mai?
    xulrunner (it) mi dice che non è compatibile con ff3.5

    • 24 luglio 2009 alle 2:50

      controlla che file ci sono in /etc/fonts/conf.d

      l’altro non è un problema, semplicemente il pacchetto della lingua di ff 3.0 non è ovviamente compatibile con ff 3.5 e te lo segnala.

  68. 23 luglio 2009 alle 18:43

    Ciao Guiodic.
    Oggi’ tra gli aggiornamenti di Jaunty mi escono quelli a Firefox 3.0.12.
    Cosa devo fare? Faccio fare l’upgrade o no?….
    Non vorrei ritrovarmi senza firefox 3.5.1

    Gli aggiornamenti proposti riguardano Firefox 3.0, Firefox gnome support, xulrunner 1.9
    Praticamente cosa dovrei fare?
    evitare l’aggiornamento di FF 3.0 (togliendo la spunta)
    poi
    Andare in Synaptic e Bloccarne la versione

    ??

    Dal basso della mia inesperienza mi vien da dire:
    non faccio prima ad eliminare del tutto i pacchetti di firefox 3.0?
    O sono indispensabili per firefox 3.5?
    E se sono indispensabili… che male c’è ad aggiornarli?

    Spero di essere stato chiaro…….

    • 24 luglio 2009 alle 2:49

      puoi fare tranquillamente l’aggiornamento, non riguarda Firefox 3.5

      Se vuoi puoi eliminare FF3.0 ma se ne fa il pacchetto java plugin, però è possibile continuare ad usare java lo stesso creando un link simbolico così:

      sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so /usr/lib/firefox/plugins

      • Doc
        7 agosto 2009 alle 15:23

        Invece, proprio nei giorni scorsi ho constatato che hanno “corretto” o, se preferite, “adeguato” le dipendenze: ora il java plugin PUÒ essere installato con FF3.5, senza ritrovarsi anche FF3.
        Verificato sia su i386 sia su AMD64!
        Ciao a tutti.

  69. ciccoale
    23 luglio 2009 alle 18:46

    Ciao senti il gestore aggiornamenti mi propone di aggiornare firefox alla 3.0, ovviamente li ho bloccati, se dovessi aggiornare sparisce firefox 3.5? Ci sono molti utenti sul forum 8soprattutto principianti) che chiedono aiuto al riguardo…

    • 24 luglio 2009 alle 2:45

      no, non sparisce.

    • 7 agosto 2009 alle 18:20

      no, non sparisce niente, basta rifare l’ultimo passaggio della guida, quello del link

  70. rc
    23 luglio 2009 alle 21:35

    ciao, grazie per l’ottima guida, un unico problema, quando digito i comandi: sudo cp /usr/lib/firefox-3.0.11/chrome/icons/default/default* /usr/lib/firefox-3.5.1/chrome/icons/default
    sudo cp /usr/lib/xulrunner-1.9.0.11/icons/mozicon* /usr/lib/xulrunner-1.9.1.1/icons/
    sudo cp /usr/lib/firefox-3.0.11/icons/mozicon* /usr/lib/firefox-3.5.1/icons/
    il terminale mi rimanda: impossibile eseguire stat di ” ” nessun file o directory
    questo succede per ognuno dei comandi
    firefox 3.0.11 è tutt’ora installato ed ho installato firefox 3.5.1 su jaunty…….grazie per l’aiuto!

    • 24 luglio 2009 alle 2:45

      vuol dire che non trova dei file ma ” ” non significa niente…
      non capisco cosa può essere… prova a ridare i comandi e controlla bene di non mettere spazi nel percorso o cose di questo tipo

    • 24 luglio 2009 alle 2:58

      non è che hai aggiornato al 3.0.12 ?

  71. damko
    23 luglio 2009 alle 22:07

    Attenzione!
    per chi ha hardy, e a quanto pare anche la 8.10, puo succedere che il passaggio a > 3.5 crei dei problemi ad epiphany. cfr https://bugs.launchpad.net/ubuntu/+source/epiphany-browser/+bug/302859
    in poche parole succede che a causa dell’installazione di xul 1.9.2 la addressbar di epiphany smette di funzionare: in pratica ci si puo scrivere ma nè l’invio ne il premere il tasto GO consentono la navigazione.
    per risistemare la faccenda basta rimuovere xul 1.9.2 ma chiaramente rimuove anche l’ultimo FF

    ho visto che hanno preparato un diff ma non l’ho provato. aspetto il rilascio ufficiale

    enjoy
    Dam

  72. ciccoale
    23 luglio 2009 alle 22:51

    @ rc

    può essere che hai installato la 3.0.12, in quel caso devi cambiare directory… non è più 3.0.11

    @ guiodic

    come faccio a cambiare avatar nel tuo blog? :-D

  73. 24 luglio 2009 alle 8:15

    avevo già controllato e questo non cè: 10-hinting-slight.conf .
    ci sono: 10-hinting.conf , 10-antialiasing.conf e 10-hinting-medium.conf.
    ciao!

    • 24 luglio 2009 alle 10:52

      boh, strano, comunque magari prova con quelli che ci sono.

  74. playwords
    24 luglio 2009 alle 9:56

    Ok, ho provato a leggere tutti i post prima di fare la mia “aggiunta” e non ho visto lo stesso caso quindi, se a qualcun’altro capitasse…

    A questo comando:

    sudo cp /usr/lib/xulrunner-1.9.0.11/icons/mozicon* /usr/lib/xulrunner-1.9.1.1/icons/

    Vi desse un errore, di tipo:

    cp: impossibile eseguire stat di “/usr/lib/xulrunner-1.9.0.11/icons/mozicon*”: Nessun file o directory

    com’è successo a me, controllate che anziché xulrunner-1.9.0.11 non sia xulrunner-1.9.0.12.

    Per il resto, già lo avevo installato shiretoko, ma con il tuo post ho perfezionato le cose in sospeso ;-).

  75. Mithrandir
    25 luglio 2009 alle 15:40

    ora funziona il link http://www.megaupload.com/?d=AUTK0QF6 funziona si, anche se usando quel componente youtube crasha, non so perchè. L’ho disinstallato e ora funziona perfettamente.
    Grazie comunque per l’ottima guida.
    Avendo 8.04 Hardy Heron ho aggiornato alla 3.5 e non la 3.5.1.
    Può darsi che non abbia capito dai posts precedenti, ma è possibilie installare la 3.5.1 su 8.04?

    • 25 luglio 2009 alle 16:38

      stranamente ancora non hanno aggiornato il repository.
      Eventualmente puoi usare il repository mozilla-daily

  76. Mithrandir
    26 luglio 2009 alle 0:55

    bene, allora aspettiamo, quando uscirà spero che non sarà difficile fare l’upgrade :)

  77. Jay
    26 luglio 2009 alle 11:30

    Ho aggiornato tramite i mozilla-daily…ora finalmente (su intrepid) ho firefox aggiornato. L’unico problema rimane la lingua che essendo la 3.5.2pre il pacchetto della 3.5.1 non è compatibile..

    • 26 luglio 2009 alle 17:07

      potresti provare a modificare il pacchetto della lingua di firefox 3.5.1, lo apri con il gestore archivi e poi guarda nel file install.rdf, verso la file c’è una riga che indica la versione con cui è compatibile.

  78. Merlinux
    26 luglio 2009 alle 15:05

    Ottima guida!!!

  79. ani_d
    29 luglio 2009 alle 18:27

    Ho installato tutto bene seguendo la tua guida ma mi restano due dubbi (probabilmente da niubba…):

    Da Strumenti-> componenti aggiuntivi -> estensioni vedo che è installato Ubuntu Firefox Modifications 0.7
    ma synaptic invece mi dice che il pacchetto non c’è. Ad ogni modo sembra non esserci perchè il mattoncino di cui parli non lo visualizzo e i video delle pagine li vedo col player della pagina stessa.

    Da Strumenti->componenti aggiuntivi->lingue ho questo:
    Xulrunner (it) 1.9.0.8 non compatibile con Firefox 3.5.1

    E’ grave?

  80. saramago
    2 agosto 2009 alle 14:28

    scusa ,ma perchè seguendo la tua guida al passo dopo il passo tre mi ritrovo installato la versione 3.5.3 ?quindi il pacchetto in ligua italiana non è compatibile?
    Uso ubuntu jaunty 9.04 e quindi sono partito dal punto 3 come hai indicato sulla guida.
    Ho provato a rimuovere e ripartire da zero ma il risultato è sempre lo stesso mi ritrovo con shiretoko 3.5.3pre
    Dove sbaglio?

    • 2 agosto 2009 alle 18:24

      se hai la 3.5.2 (non 3) vuol dire che hai aggiunto i repository mozilla-daily. Dovresti disabilitarli da sorgenti software, disinstallare firefox 3.5 e reinstallarlo.

      • saramago
        3 agosto 2009 alle 20:47

        Sei grande,grazie per la guida e per il suggerimento.
        Tutto a posto
        grazie

  81. Andrea
    5 agosto 2009 alle 15:21

    Ho un problema che è sorto dopo un po’ che ho installato firefox su ubuntu 9.04 seguendo questa guida: non mi salva più le password e quelle salvate non riesco ad eliminarle.

    Sono andato sulla console errori in strumenti e mi viene fuori questo messaggio quando tento di salvere una password:

    Errore: uncaught exception: [Exception… “‘Couldn’t write to database, login not added.’ when calling method: [nsILoginManagerStorage::addLogin]” nsresult: “0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)” location: “JS frame :: file:///usr/lib/xulrunner-1.9.1.1/components/nsLoginManager.js :: anonymous :: line 451″ data: no]

    Qualcuno ha qualche idea??

    é successo solo a me??

    • 5 agosto 2009 alle 16:18

      forse è un problema di permessi nella cartella .mozilla, prova a mettere i permessi di lettura e scrittura e applicarli a tutti i file. Eventualmente da terminale è semplice:

      chmod -R 777 .mozilla

  82. pioneers
    5 agosto 2009 alle 21:50

    grazie per le dritte amico, non capivo perchè non dopo aver installato i pacchetti non mi si collegava a niente, bastava sconnettersi e ricollegarsi…

  83. oStile17
    7 agosto 2009 alle 12:12

    Ciao Guido,
    ho aggiornato dalla 3.5.1 alla 3.5.2 su Ubuntu 9.0.4 ma stavolta non mi fa cambiare l’icona. Infatti le directory relative a Firefox dentro /usr/lib non ci stanno! Mi è rimasto sia il nome Shiretoko, sia l’icona col mondo! Cosa può essere? Inoltre, nonostante abbia deselezionato i repository proposed, continua a volermi aggiornare Firefox 3.0 che credo non si sia mai disinstallato! Hai qualche suggerimento?

  84. 9 agosto 2009 alle 15:13

    Se chiami questa perfezione e integrazione col sistema abbiamo concetti molto diversi in tal senso. :) Con Ubuntuzilla è tutto molto più veloce, più semplice, e più integrato (oltretutto l’antialiasing funziona, ed è la build ufficiale, basta sapere cosa modificare).

    http://andrealazzarotto.com/2009/08/09/firefox-3-5-su-ubuntu-la-risposta-e-ubuntuzilla/

  85. digian05
    10 agosto 2009 alle 12:16

    Grazie mille, funziona benissimo.
    Unico neo: icona bianca (anonima) nell’ Avant Window Navigator.
    Icone pannelli, applicazioni ecc: OK
    Saluti

  86. Fiorenzo
    10 agosto 2009 alle 14:49

    Salve,
    grazie della guida, l’ho trovata molto utile ed esaustiva. Volevo tuttavia domandare se Firefox 3.5.2 possa in qualche modo bloccare il sistema.
    Mi è capitato, da quando uso quest’ultima versione, che il sistema mi vada totalmente in blocco e l’unica soluzione possibile è spegnere brutalmente il portatile e riaccenderlo. Credo che sia Firefox 3.5.2 perchè usando la versione precedente non mi sta succedendo. A seguto di questo, mi domandavo se qualcuno ha problemi simili ed eventuali soluzioni. Grazie mille. Saluti

  87. abecchio
    13 agosto 2009 alle 0:08

    guido scusa ma non ho ben capito una cosa…

    Ora, al percorso “Applicazioni–>Internet” ho ancora l’icona di shiretoko assieme a quella di Firefox. Se resto fermo con il mouse sopra all’icona del primo mi appare la tendina con scritto “Firefox 3.5″

    Ho 2 Link per lo stesso programma?

    • 13 agosto 2009 alle 0:34

      No, hai due link perché con questa guida tieni installate 2 versioni di Firefox, la 3.0 e la 3.5. Per questo che il “per bene” del titolo personalmente non lo condivido.

    • 13 agosto 2009 alle 0:36

      Puoi toglierlo.

  88. abecchio
    13 agosto 2009 alle 10:14

    @lazza:
    Beh… nel titolo indica che con questa guida si installa la versione 3.5.2… ma non dice che la 3.0 verrà eliminata!

    @guido:
    Per eliminare firefox 3.0?

    sudo apt-get purge –remove firefox-3.0

    grazie ;)

    • 13 agosto 2009 alle 10:16

      sudo apt-get remove firefox-3.0 oppure sudo apt-get purge firefox-3.0. Non come l’hai scritto tu :)

  89. abecchio
    13 agosto 2009 alle 11:21

    Oro… grazie infinite Guido!

    p.s. intendevo scrivere sudo apt-get purge (doppio trattino)remove firefox-3.0

    ma non voglio essere petulante, ascolterò IL guru :)

  90. elfu
    13 agosto 2009 alle 11:41

    Salve, nel menu internet anche io ho presenti 2 collegamenti (“Shiretoko web browser” e “Firefox browser web”) ma nonstante quando detto entrambi mi portano alla 3.5.2.
    Avrei esigenza di lavorare anche con la 3.0, com’è possibile avviarla e magari ripristinare il collegamento? Scusate l’ignoranza…

    • 13 agosto 2009 alle 11:44

      tasto detro sull’icona di ubuntu > modifica menu. Cerca Firefox in applicazioni > internet, clicca su “modifica” e cambia il comando da “firefox” a “firefox-3.0″

  91. c.g.
    14 agosto 2009 alle 11:09

    ma è + veloce rispetto al 3?

    • 14 agosto 2009 alle 11:46

      Sì! :D

    • 14 agosto 2009 alle 12:55

      Se è più veloce? Neanche a paragonare! È straordinario, e con le nuove funzioni presto farai fatica a farne a meno. ;)

  92. airport93
    15 agosto 2009 alle 15:24

    Si sa se in futuro Firefox supporterà anche formati video proprietari (con codec liberi) come fa ora chrome?

    • 15 agosto 2009 alle 15:25

      Guarda che lo fa già. O.O

      • airport93
        15 agosto 2009 alle 15:42

        A quanto mi risulta supporta solo formati liberi (tipo ogg), mentre chrome tramite i codec liberi di ffmpeg legge anche i formati proprietari (ma perché mi ha il commento così in alto invece che in fondo?).

        • 15 agosto 2009 alle 15:51

          Il commento è qua perché hai replicato ad un altro commento e non all’articolo originale. Si chiamano commenti innestati e a me non piacciono per nulla, ma vabbè qua ci sono e accontentiamoci.
          Ad ogni modo magari tu intendi il tag “video”, però gli embed funzionano benissimo con Totem Gstreamer da un sacco di tempo…

          • airport93
            15 agosto 2009 alle 16:03

            Ops, non mi ero accorto di aver premuto su Replica.
            Sì, intendevo proprio il tag video. So già che con totem gestreamer si vedono bene gli embed, ad ogni modo ero solo curioso di sapere se nell’inclusione di formati proprietari tramite codec liberi Firefox si sarebbe accodato a chrome o meno.

    • 15 agosto 2009 alle 16:28

      Quasi sicuramente no. Però è possibile che qualcuno scriva un’estensione che aggiunga questa funzione.

      • airport93
        15 agosto 2009 alle 17:10

        Grazie della risposta Guiodic ;). Ma così Firefox non rischia di restare indietro? Con le aziende che spingono verso l’adozione di codec proprietari per il tag video (che mi risulta non standardizzato per quanto riguarda il codec da usare), nor rischia di essere superato da altri browser?

        • 15 agosto 2009 alle 17:57

          Considerando la penetrazione di Firefox in confronto ad altri browser, forse è il contrario, al limite saranno i portali video a doversi adattare :)

          • airport93
            15 agosto 2009 alle 19:14

            Grazie, è esattamente quello che speravo di sentire :D.

  93. 17 agosto 2009 alle 10:51

    Chi come me usando Hardy è rimasto su FF 3.5 può sempre ripiegare su GNU IceCat. Di seguito il repo con i pacchetti per Ubuntu da me creati: https://launchpad.net/~sumydi/+archive/icecat-pkgs

  94. aquilone
    17 agosto 2009 alle 15:25

    ciao.
    non so voi, ma Firefox 3.5.2 non mi vuole salvare automaticamente le password.
    Mi spiego meglio:
    quando faccio il login in un sito, inserendo nome utente e psw, esce la classica barra pop up che ti chiede se Ricordare, Mai per questo sito, Non adesso.
    Ebbene io clicco come al solito su Ricorda, ma la barra non scompare e al successivo accesso a quel sito devo reinserire a mano ogni volta la password.

    Che succede?

    grazie!

    • 17 agosto 2009 alle 15:28

      non è che hai qualche problema di permessi con la directory .mozilla?

      • aquilone
        17 agosto 2009 alle 15:35

        Mh… come posso verificare?

        • aquilone
          17 agosto 2009 alle 15:37

          comunque non mi pare… la cartella .mozilla in proprietà mostra tra i permessi il mio nome… come al solito… e non il root…

          • 17 agosto 2009 alle 15:57

            prova così. rinomina la cartella .mozilla come .mozilla-backup (o come ti pare) e riavvia firefox.

          • aquilone
            17 agosto 2009 alle 17:10

            Nel momento in cui l’ho rinominata mi sono accorto …o meglio secondo me è apparsa improvvisamente… che le cartelle .mozilla erano due (una rinominata da me .mozilla-backup).
            Eliminata quella in eccesso funziona tutto.
            Grazie guiodic, prezioso come sempre.

            P.S. E’ ora possibile eliminare la versione 3.0 di Firefox o rimane il problema che si porta via con se il pacchetto di java?

          • 17 agosto 2009 alle 17:22

            sì è possibile eliminarla, per tenere java bisogna creare un link, controlla in questi commenti, c’è un utente che l’ha scritto.

  95. MasterPJ
    17 agosto 2009 alle 22:27

    guiodic, dammi un parere:
    avevo seguito questa guida per firefox 3.5, tutto perfetto (anzi, grazie!). Poi con l’aggiornamento 3.5.1 mi si è azzerato tutto (è tornato shiretoko). Al che mi sono rotto e ho installato la versione non “ubuntizzata” di firefox 3.5.1, ma quella ufficiale mozilla, tramite lo script Ubuntuzilla, che permette di fare gli update automatico e fa tutto lui. Da quando lo uso tutto perfetto, nessun crash o problema di sorta.
    In questo modo mi pare più comodo e veloce, che dici?

    • 17 agosto 2009 alle 22:33

      A me non pare perché la versione che scarichi dal sito non è compilata per il supporto di pango e quindi l’hinting perfetto dei caratteri, sia nelle pagine che nell’interfaccia.
      Per riavere forefox come prima bastava seguire gli ultimi passaggi della guida una seconda volta per copiare le icone. Tutto qui.

      • MasterPJ
        17 agosto 2009 alle 22:48

        A me sembra tutto perfettamente identico visivamente, sia come interfaccia sia per i caratteri…

        • 17 agosto 2009 alle 22:51

          Dipende dal monitor che hai. Inoltre è probabile che le modifiche fatte ai caratteri si siano ripercosse almeno in parte anche su Firefox perso con Ubuntuzilla. In generale io consiglio sempre di usare i pacchetti deb e/o i repository in modo da avere un sistema uniforme di installazione, aggiornamento e disinstallazione.

          • MasterPJ
            17 agosto 2009 alle 22:55

            Può essere… cmq è da provare. Mi son trovato molto bene, fa tutto in pochi secondi e si aggiorna con notifiche automatiche. Se hai tempo da perdere ti consiglio di darci un occhio. Quanto meno anche per i niubbi sarebbe un metodo ottimo da proporre fra le tue guide (almeno finchè dai rep non si scarica firefox come si deve e non shiretoko).

          • 17 agosto 2009 alle 23:02

            Ok, sarà facile e sicuro, ma io proprio non approvo metodi alternativi ai deb. Magari in un caso va bene, come per Ubuntuzilla, nel 90% dei casi va malissimo, si sovrascrivono librerie, si duplicano librerie, non si capisce come disinstallare, ecc.
            Ad esempio è il caso di realplayer, di google earth, di mainactor, di java e di molti software proprietari.
            Lo scopo di questo blog è insegnare agli utenti a usare Ubuntu come di deve, ovvero per come è stata progettata, cioè con APT e i pacchetti deb.

          • MasterPJ
            18 agosto 2009 alle 10:54

            Su questo hai ragionissima! Infatti mi sono rivolto a questo script solo perchè “quelli di Ubuntu” non hanno ancora messo il ramo 3.5 correttamente sui loro repository. E’ infatti un’eccezzione, per tutto il resto uso anch’io i rep con relative chiavi, o in casi particolari se non ci sono rep, i pacchetti deb.

          • 18 agosto 2009 alle 11:09

            Però su jaunty c’è. Non c’è bisogno neppure di repo esterni.

  96. Sandro
    18 agosto 2009 alle 9:34

    Ciao Guiodic, cosa ne pensi del browser Epiphany? Io l’ho usato con soddisfazione per parecchio tempo (anche se ora sto usando Firefox 3.5.2).. Scusa il leggero OT ;)

    • 18 agosto 2009 alle 11:08

      @Sandro: di Epiphany ne penso tutto il bene possibile :D

  97. MasterPJ
    18 agosto 2009 alle 11:12

    No, su jaunty scarichi la Shiretoko che poi va modificata come da tua guida, non scarichi la 3.5.2 gia fatta e finita.

  98. abecchio
    18 agosto 2009 alle 18:39

    Ciao guido… scusa se magari inserisco una domanda precedentemente già esposta ma sono un pò tanti i commenti…

    Praticamente ogni volta che provo a mettere in fullscreen un filmato da youtube, facebook et similia mi si crasha firefox 3.5.2 chiudendosi automaticamente…

    Succede solo a me?

    grazie ;)

    • 18 agosto 2009 alle 18:46

      Che scheda grafica hai? Nvidia per caso?

      • abecchio
        18 agosto 2009 alle 18:50

        Sì… ASUS EN8400GS Silent

        • 18 agosto 2009 alle 19:11

          prova così:

          sudo gedit /usr/lib/firefox-3.5.2/firefox.sh

          prima della riga MOZDIR=$HOME/.mozilla (che trovi all’inizio) aggiungi questa riga:

          LD_PRELOAD=/usr/lib/libGL.so.1

          salva, poi riavvia firefox.

          • abecchio
            18 agosto 2009 alle 19:20

            Fatto… crasha ancora!

            torno al vecchio firefox?

          • 18 agosto 2009 alle 19:43

            prova a lanciare FF da terminale così:

            LD_PRELOAD=/usr/lib/libGL.so.1 firefox

          • abecchio
            18 agosto 2009 alle 20:06

            crasha nuovamente :(

          • 18 agosto 2009 alle 20:54

            @abecchio: prova a disattivare compiz, vediamo se dipende da quello.

  99. Scugnizzo
    19 agosto 2009 alle 12:36

    Non so se è un problema solo mio….ma da quando ho installato FF 3.5 ho notato che visitando pagine con javascript l’utilizzo di cpu sale di parecchio.
    Sono io che me ne sto accorgendo solo ora o è normale?

  100. leopesto
    24 agosto 2009 alle 15:36

    guio, ho un problema grande come una casa!!!

    ho installato la 3.5.2 pensando di risolverlo…ma continuo ad avere sempre lo stesso problema…

    ogni volta che qualcuno sta su firefox a far qualsiasi cosa su uno dei pc di casa, sugli altri non posso accedere al forum di ubuntu!!!
    cioé, metti che mia mamma cerca voli sul suo pc, io sul mio posso fare di tutto tranne entrare nel forum di ubuntu che sta tutto il tempo a caricare finche non viene fuori errore, il server non risponde o qualcosa cosi…
    sono sicuro che il problema é quando qualcuno usa firefox su un’altro pc perché chiudendolo, ubuntu-it si carica…

    chiedo aiuto a te che vedo ne sai parecchio….

    grazie in anticipo ;), Leo

    • 24 agosto 2009 alle 15:43

      Ah guarda… è una cosa che non avevo mai sentito prima! Solo il sito di Ubuntu non ti funziona?

      • leopesto
        24 agosto 2009 alle 15:45

        si, solo quello!! é stranissimo lo so, pero é cosi!!
        non va sia il sito che il forum!

        • leopesto
          24 agosto 2009 alle 16:00

          Tempo per la connessione esaurito

          Il server forum.ubuntu-it.org sta impiegando troppo tempo a rispondere.

          * Il sito potrebbe non essere disponibile o sovraccarico. Riprovare fra qualche momento.

          * Se non è possibile caricare alcuna pagina, controllare la connessione di rete del computer.

          * Se il computer o la rete sono protetti da un firewall o un proxy, assicurarsi che Firefox abbia i permessi per accedere al web.

          • leopesto
            24 agosto 2009 alle 23:20

            scusami se rompo…non sai come risolvere???

          • 25 agosto 2009 alle 0:57

            @leopesto: francamente non lo so.

  101. Franco
    24 agosto 2009 alle 23:22

    Ottima guida.
    Grazie

    Franco

  102. 25 agosto 2009 alle 14:27

    Davvero un bell’articolo, ben scritto e soprattutto “UTILE”. Sulla rete c’è di tutto, ma di articoli così se ne trovano pochi.

  103. Roberto
    1 settembre 2009 alle 10:00

    Ciao Guiodic innanzitutto complimenti per il blog e per la guida di ff 3.5.2..

    Volevo chiederti perchè molte volte non riesco a visualizzare alcune pagine web, ma la cosa strana è che non sempre capita con la stessa pagina. Cioè magari una pagina che ho visualizzato il giorno prima poi non riesco a vederla il giorno dopo. Alcune volte, ma nn sempre mi capita di risolvere premendo il tasto f5 fino allo spasmo.

    • 1 settembre 2009 alle 19:56

      capita solo con ff 3.5.2 o anche con altri browser?

      • Roberto
        1 settembre 2009 alle 20:49

        Ho solo ff 3.5.2 con altri nn ti saprei dire. Però usando IE con win ho notato che una delle pagine che nn riesco ad aprire con ff utilizza JAVA.

        • 2 settembre 2009 alle 13:39

          JAVA o javascript? sono cose molto differenti.
          javascript c’è ormai in tutte le pagine web.

          Comunque se invece il problema è davvero java, allora probabilmente hai il plugin icedtea invece che quello sun

          Cerca su sinaptic icedtea plugin e openjdk , disinstallali e installa sun java 6 plugin.

          • Roberto
            2 settembre 2009 alle 14:30

            Confermo JAVA. Ho provato anche a reinstallare sun java6 plugin che già avevo installato ma niente. Ho addirittura provato con il plugin icedtea, poi rimosso, ma nache così, picche!

          • 2 settembre 2009 alle 21:04

            mi dai un link così controllo?

          • Roberto
            3 settembre 2009 alle 9:46

            Uno dei link è http://www.dhgate.com oppure http://www.esprinet.com sono entrambi siti per acquisti on line. Il problema nasce quando cerco di accedere alle pagine del mio account e alle varie sottosezioni come magari ultimi acquisti, stato di spedizione ecc.

          • 4 settembre 2009 alle 23:06

            facciamo così, iscriviti qui: http://www.linuxqualityhelp.it

            continuiamo lì.

          • mattia
            21 dicembre 2009 alle 21:06

            aia!!! l’aggiornamento di oggi ha fatto un pò di casini…
            caro guiodic, fai conto che ho seguito la tua guida alla lettera e tutto ok. oggi però dopo l’aggiornamento parte firefox 3.0.16
            n.b.:
            da synaptic ci sono ancora i pacchetti firefox-3.5

            many thanks

          • mattia
            22 dicembre 2009 alle 9:36

            ho risolto da solo….aveva semplicemente rimosso il link a firefox-3.5
            ho dato
            ln -s firefox-3.5 firefox
            e adesso funonzia

            bye

          • Roberto
            5 settembre 2009 alle 1:47

            Ok iscrizione effettuata. In attesa di conferma!

  104. Danielsan
    3 settembre 2009 alle 1:06

    Azz, pensavo fosse una guida per Jaunty!!!
    Perché non ho letto con più attenzione?
    Ho passato un pomeriggio a imprecare per i danni fatti da Ubuntuzilla su Xubuntu Hardy!!!!!
    Voglio subito installare FF 3.5 perché sulla 8.04, sin da subito, ho sempre notato un certo conflitto da tra FF 3 e Xorg è stata la molla che mi ha spinto ad usare Epiphany.

  105. digian05
    3 settembre 2009 alle 17:47

    Volevo solo saper se si aggiorna automaticamente (previo notifica).

  106. mauro
    6 settembre 2009 alle 10:31

    Complimenti e grazie, guide sempre chiare e esaurienti.Tutto bene, installazione F.F.3.5 a buon fine. Grazie ancora,buon lavoro.

  107. uche
    11 settembre 2009 alle 13:32

    grazie, guida perfetta, semplice, sei un grande!

  108. 13 settembre 2009 alle 11:45

    Avevo seguito questa tua guida per installare il 3.5.2 su jaunty e tutto ha funzionato alla perfezione, ma correggimi se sbaglio a ora sul repository ufficiale di jaunty non c’e’ ancora la 3.5.3….

    E’ il caso di aspettare ?

    grazie,

    ar3ac

    • 13 settembre 2009 alle 16:54

      c’è :)

      • 13 settembre 2009 alle 17:59

        Ho ricontrollato adesso, firefox 3.5.3 non c’è…ho guardato anche su http://packages.ubuntu.com ci sta solo 3.5.2….
        non è che da te lo prende dal repository su launchpad ?

  109. calz
    17 settembre 2009 alle 8:21

    tutto alla perfezione! unica cosa è il consumo di memoria che non corrisponde. i due firefox (3.0 e 3.5) con aperta questa pagina web su entrambe, uno consuma 72 MB e l’altro 80 Mb. bisogna impostare qualcosa?
    Inoltre la mia versione è la 3.5.2, si aggiornerà da sola alla 3.5.3? ciao grazie ottima guida.

    • 19 settembre 2009 alle 2:11

      sì si aggiorna. Riguardo il consumo di memoria, è simile ma con FF 3.5 tende a liberarne di più.

  110. calz
    17 settembre 2009 alle 13:30

    mi sai dire perché con la pagina di repubblica-tv firefox crasha?
    Ho applicato il tuo suggerimento per schede invidia… ma ho verificato che mi crasha anche la 3.0.5. Prima la vedevo. sigh!

  111. claudio
    23 settembre 2009 alle 22:20

    al punto 6 Salvatelo e poi trascinatelo nella finestra di Shiretoko. Riavviate come vi viene chiesto.
    perdonami ma non sono capacissimo.
    ho scaricato e salvato sulla scrivania http://www.megaupload.com/?d=AUTK0QF6 l’ho estratto e poi???? dici di trascinarlo nella finestra di shiretocko ma dove si trova questa finestra?

    • 27 settembre 2009 alle 23:23

      e perché l’hai estratto?

      ici di trascinarlo nella finestra di shiretocko ma dove si trova questa finestra?

      quando apri shiretoko…

  112. Enigma51
    9 ottobre 2009 alle 16:39

    Bravo , seguendo il tuo procedimento ci sono riuscito ,
    Ma come mai quando ho + pagine aperte nella stessa finestra chiudo sulla X e clikko salva ed esci , poi quando rientro nel browser non mi ha salvato niente mi esce solo la home page , ciao e grazie .

  113. 13 ottobre 2009 alle 16:54

    sono su hardy, ora, a quanto pare, non è più possibile mettere la 3.5 in italiano?! :S

    http://releases.mozilla.org/pub/mozilla.org/firefox/releases/

  114. 27 ottobre 2009 alle 21:22

    Grazie infinite.
    Sono un niubbo e non sapevo proprio come salvarmi.
    Sei stato veramente prezioso.

  115. Dario
    21 novembre 2009 alle 21:08

    Ciao, ho un problema…
    guida perfetta… ma non so il perchè se mi collego su facebook la chat non va come al solito, mi si fa un pulsante all’angolo basso destro che, cliccandoci, mi apre la chat in una nuova finestra che forse è sempre esistito a cui, però, non avevo mai fatto caso…. però il solito menu a tendina per la chat non c’è. A parte queso il browser va bene… e ultima cosa la barretta le lampeggia (il puntatore della scrittura per intenderci) diventa enorme lampeggiante(per metà) sito internet se clicco in qualsiasi sito in alto a sinistra come se volessi iniziare a selezionare del testo… ma senza trascinare il cursore, facendo un solo clic. In pratica questo cursore gigante mi copre metà sito e devo cliccare altrove per rimediare cosa che cono firefox 3.0 non succedeva.

    • 21 novembre 2009 alle 22:11

      hai salvato il passaggio dove cambiare il nome del browser in about:config

      • Dario
        22 novembre 2009 alle 17:51

        Allora grazie mille per la dritta perchè ho risolto il problema solo che quel passaggio io l’avevo fatto inserendo Firefox/3.5.3 solo che non andava ho dovuto inserire Firefox/3.5 anche perchè sono con Hardy e dai repo non mi da ne la 3.5.2 tanto meno la 3.5.3 passa direttamente alla 3.6.
        Ho notato che se rimuovo la 3.0.14 alcuni componenti aggiuntivi non funzionano bene tipo tabmixplus non mi dava più i pulsanti per ripristinare le finestre chiuse nella barra e non me li faceva riaggiungere.

        Ti chiedo un’ultima cosa ora quando clicco su un link che mi da un’amico in chat (qualsiasi client) mi si apre sempre firefox 3.0.14 invece che una nuova tab di shiretoko mi sai dire come si cambia questa cosa?

        • 22 novembre 2009 alle 18:17

          se segui *tutta* la guida il problema non si presenta.

  116. Dario
    22 novembre 2009 alle 12:54

    Ciao guiodic… non so il perchè il messaggio che ho inserito non si è ordinato nella cronologia dei commenti. E’ a metà dove tu rispondi ad un’altra persona chiedendo di non spammare….

  117. 22 dicembre 2009 alle 1:45

    devi ricreare il link simbolico in /usr/bin/

  118. gelle
    13 gennaio 2010 alle 18:16

    ciao,
    ho ubuntu hardy.
    Inserita la riga dei repo nella lista e poi la chiave, ma nè synaptic e nè apt dal terminale trovano firefox 3.5…
    come mai?
    ciao grazie…

    • 14 gennaio 2010 alle 13:04

      Ciao, apri un topic su http://www.linuxqualityhelp.it

      • gelle
        14 gennaio 2010 alle 16:22

        ok, grazie…
        ma ho più o meno risolto, installando icecat 3.5.7…

        Mi iscrivo comunque a linuxqualityhelp per gli altri problemi che sicuramente avrò…
        ciao grazie ancora.

  119. 28 giugno 2013 alle 20:52

    Thanks for another excellent article. Where else may anybody get that kind of information in such a perfect
    approach of writing? I’ve a presentation subsequent week, and I am at the search for such info.

  120. 29 luglio 2013 alle 20:15

    Ciao, ho un problema…
    guida perfetta… ma non so il perchè se mi collego su facebook la chat non va come al solito, mi si fa un pulsante all’angolo basso destro che, cliccandoci, mi apre la chat in una nuova finestra che forse è sempre esistito a cui, però, non avevo mai fatto caso…. però il solito menu a tendina per la chat non c’è. A parte queso il browser va bene… e ultima cosa la barretta le lampeggia (il puntatore della scrittura per intenderci) diventa enorme lampeggiante(per metà) sito internet se clicco in qualsiasi sito in alto a sinistra come se volessi iniziare a selezionare del testo… ma senza trascinare il cursore, facendo un solo clic. In pratica questo cursore gigante mi copre metà sito e devo cliccare altrove per rimediare cosa che cono firefox 3.0 non succedeva.

  121. 2 luglio 2009 alle 21:32

    Grazie ma non è il caso di spammare.

  122. ju
    4 agosto 2009 alle 14:46

    @guiodic

    Ho saltato il fosso e seguito la tua guida: tutto perfetto, grazie!

    Domanda: per installare ho trovato tutto nei repo di jaunty, per gli aggiornamenti successivi che si fa, bastano i repo di default o bisogna aggiungere qualcosa?

  123. 9 agosto 2009 alle 15:17

    Se uno viene sul tuo blog a inserire link di approfondimento completamente in-topic lo chiami spam? Io di solito i miei lettori li ringrazio se mi permettono di avere maggiori informazioni su ciò che mi interessa. Vabbè, punti di vista.

  124. 4 agosto 2009 alle 15:09

    dovrebbe bastare lasciare i repo di default, è già avvenuto l’aggiornamento dalla 3.5 alla 3.5.1 quindi ….

  125. ju
    4 agosto 2009 alle 15:35

    Ok!

    Moonshine e moonlight sono ancora incompatibili, ma penso sia questione di tempo….magari scompaiono dalla faccia della terra :-)

  126. 9 agosto 2009 alle 15:19

    Io sto guardando ora Rai.tv da Firefox 3.5 (installato con Ubuntuzilla naturalmente), funziona divinamente.

  1. 1 luglio 2009 alle 20:49
  2. 3 luglio 2009 alle 14:46
  3. 4 luglio 2009 alle 2:22
  4. 4 luglio 2009 alle 20:50
  5. 6 luglio 2009 alle 15:53
  6. 9 luglio 2009 alle 12:00
  7. 10 luglio 2009 alle 15:08
  8. 18 luglio 2009 alle 10:57
  9. 20 luglio 2009 alle 12:30
  10. 26 luglio 2009 alle 20:36
  11. 1 agosto 2009 alle 22:48
  12. 17 agosto 2009 alle 12:27
  13. 27 agosto 2009 alle 19:50

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

Iscriviti

Ricevi al tuo indirizzo email tutti i nuovi post del sito.

Unisciti agli altri 732 follower

%d blogger cliccano Mi Piace per questo: