Home > GNU/Linux, Guide pratiche GNU/Linux > Risolvere il problema della webcam su Ubuntu Intrepid Ibex

Risolvere il problema della webcam su Ubuntu Intrepid Ibex

9€)

la mia sfigatissima webcam (costo: 9€)

Come è noto, Ubuntu Intrepid ci arriva con un ben bug di Video4Linux, l’infrastruttura del kernel che si occupa dell’acquisizione video.

Risultato: delle webcam che prima funzionavano a puntino adesso non funzionano più, tra cui la mia.

Nei giorni scorsi ho downgradato il kernel alla versione 2.6.24 (quella di Hardy) per risolvere almeno temporaneamente il problema.

Poi ho trovato sul forum di Ubuntu una soluzione definitiva, segnalata peraltro qui da No Concept.

Seguendo questo post operiamo così:

1. aggiorniamo la libreria v4l: basta aggiungere il repository

deb http://ppa.launchpad.net/lool/ubuntu intrepid main

e aggiornate. Se non vi ricordate come si fa ad aggiungere un repository, seguite queste istruzioni.

2. Se non bastasse, editate il file /etc/profile con i permessi di root e aggiungete questa riga:

export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so

Quindi riavviate.

Ora la webcam su Skype e amsn funziona, finalmente.

  1. telperion
    5 novembre 2008 alle 17:55

    io mi chiedo, perchè dopo beta rc e stabile, essendo disponibile la soluzione su un ppa, non venga inserita in proposed backport o vattelapesca, ma rimangano i bug aperti per tempi tendenti all’infinito.

    Non uso la cam quindi non mi tange, ma il fenomeno “aggiustati coi workaround” su xBuntu è … mettici tu l’aggettivo negativo.

    Mah, boh e bah.

  2. ggiacomoo
    5 novembre 2008 alle 23:06

    ciao… ho provato…
    ad seguire i 2 consigli, ho messo la libreria 0.53, esportato la variabile… ma…

    $ cheese
    libv4l2: error dequeuing buf: Errore di I/O

    su skype funziona, ma si vede malissimo, sdoppiato,interlacciato,sovrapposto,colori storti… di tutto!

    p.s. sulla 8.04 funzionava egregiamente la mia acer orbicam…

    altri suggerimenti per farla tornare a funzionare??? grazie!

  3. 7 novembre 2008 alle 1:11

    @telperion: me lo chiedo pure io… capisco un minimo di test prima di prendere una cosa da un ppa qualsiasi ma… tra una libreria che sicuramente non funziona e una che per ora funziona non avrei molti dubbi.

    @ggiacomo: così è difficile dire… comunque magari apri un topic sul forum di ubuntu.

  4. Marco
    8 novembre 2008 alle 14:08

    dovrebbe essere:
    /etc/profile
    non:
    /etc/profiles

    ciao!

  5. 9 novembre 2008 alle 16:23

    @marco: sì, correggo, grazie!

  6. 10 novembre 2008 alle 14:36

    Ciao Guido,ho un problema molto simile, con l’aggravante che non riesco a far funzionare niente. Purtroppo, la 8.10 non va proprio sul mio pc: sembra partire tutto, la scritta UBUNTU su sfondo nero è quella di sempre, ma poi ci sono dei problemi -se ho capito bene- nel caricamento dell’immagine. Premesso che ho fatto update-manager -d da terminale.
    Volevo chiederti come hai fatto a “ripristinare” il sistema: qualcuno sul forum ha scritto che il downgrade non è possibile…aiuto!
    grazie
    franz

  7. Advange
    12 novembre 2008 alle 14:31

    Ciao, avevo lo stesso problema con un Acer Aspire 5570Z e una Webcam Orbicam. Premetto che funzionava solo con Vista, mai con XP. Con Ubuntu 8.10 non ha mai funzionato.
    Ho seguito i tuoi consigli, ma continua a non funzionare. Ho notato su vari forum che col comando “lsusb” dovrebbe uscire anche la webcam. Nel mio caso invece la risposta è:
    Bus 005 Device 003: ID 0402:5602 ALi Corp. Video Camera Controller
    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 003: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    Che non mi sembra la risposta corretta; a quasi tutti la risposta comprende una riga così:
    Bus 005 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam
    Ne devo dedurre che c’è qualche problema HW? tipo si è staccato qualche filo? E’ curioso come il bus 005 passi da Device 001 a Device 003.
    Aspetto consigli.

  8. 12 novembre 2008 alle 16:24

    Ciao Guido, ho un problema molto strano. Ho caricati i driver e la mia webcam funziona correttamente si su camorama che su amsn, ma su cheese e skype non me la rilevano.
    Come posso fare per frgliela rilevare????

    Grazie mille.

  9. 15 novembre 2008 alle 2:39

    lo sapevo che non dovevo mettere una guida pratica sul blog🙂

    Postate sul forum di Ubuntu, lì è meglio, qui è proprio comlicato riuscire a rispondere.

  10. 20 novembre 2008 alle 11:41

    Grazie Guiodic: ha funzionato a meraviglia.

  11. marco308
    27 novembre 2008 alle 0:00

    Ciao, complimenti per l’ottimo blog utilissimo a quelli appena passati a Gnu/linux e completamente ignoranti come me.
    Ho aggiornato le librerie come indicato ma editando il file /etc/profile con i permessi di root mi sono trovato un pò spiazzato….spero di aver editato il file corretto per prima cosa…dove inserisco al stringa da te indicata?

    Grazie mille scusate l’ignoranza e grazie ancora per l’ottimo blog

  12. 27 novembre 2008 alle 20:56

    aggiungila in fondo

  13. Gian
    12 dicembre 2008 alle 2:10

    Grazie, cheese non funzionava più e ora va benissimo..
    Grande come sempre

  14. edo vulano
    18 dicembre 2008 alle 21:16

    a me non va uffa!!!!!!!!
    e se tornassi al kernel precedente?

  15. cumparialfio
    22 gennaio 2009 alle 18:32

    grazie guiodic,
    va tutto a meraviglia con una trust 1200 wb mi dicono si vede bene con buona fluidita’( ….dall’Australia occidentale!).
    dovrebbe essere un buon test!!!

  16. Vincenzo
    24 febbraio 2009 alle 0:24

    telperion 5 Novembre 2008 alle 17:55

    io mi chiedo, perchè dopo beta rc e stabile, essendo disponibile la soluzione su un ppa, non venga inserita in proposed backport o vattelapesca, ma rimangano i bug aperti per tempi tendenti all’infinito.

    Non uso la cam quindi non mi tange, ma il fenomeno “aggiustati coi workaround” su xBuntu è … mettici tu l’aggettivo negativo.

    Mah, boh e bah.
    ——————————————————————

    Dovresti proprio imparare l’italiano. Anche impegnandomi non riesco a dare un senso compiuto alla tua frase.
    Spero tu non posti mai più un commento su un forum usando un linguaggio del genere.

    Ciao.

  17. cumparialfio
    24 febbraio 2009 alle 10:24

    x vincenzo…
    hai fatto intristire il ns guiodic!
    cosa vorresti comunicare a noi profani?

  18. 24 febbraio 2009 alle 18:31

    @vincenzo: io quello che ha scritto Telperion l’ho capito.

  19. 5 marzo 2009 alle 0:25

    Sapevo che mi sarebbe tornato utile prima o poi!
    Installata la 8.10 su un mini-itx della Intel mi si è presentato lo stesso tuo problema, risolto come da te indicato.
    Non so se è significativo, ma la mia cam è una Nortek come quella della foto.
    Ciao, Pino

  20. Franz
    7 marzo 2009 alle 20:01

    grazie mille della guida!

    domanda:
    nel prossimo rilascio di kernel avremo di nuovo lo stesso problema?
    sarebbe frustrante vedere passi indietro nella compatibilit’

  21. franz
    8 marzo 2009 alle 5:16

    mi autorispondo visto che ho scritto una mezza cavolata… di libreria trattasi e non di kernel… ad ogni modo speriamo che in jaunty il problema sia risolto

  22. davide
    12 marzo 2009 alle 14:42

    ciao, ho fatto tutto ciò che mi hai consigliato e la webcam ha cominciato a funzionare, ma si vede malissimo e su amsn non funziona. come mai? ho ubuntu 8.10 su aspire 5610z con webcam logitech orbicam. grazie

  23. Luigi
    13 marzo 2009 alle 8:33

    Ciao, scusa l’ignoamnza, io ho scaricato e installato i repository, come hai consigliato,tutto bene, ma essendo un rpofano di Gnu/Linux mi trovo in difficcoltà x come editare il file /etc/profile, mi potresti scrivere il comando completo da inserire?
    Grazie mille x l’aiuto!!!!!!

  24. pippo
    13 marzo 2009 alle 23:27

    prova

  25. 6 maggio 2013 alle 20:21

    Hello, I read your blog regularly. Your humoristic style is awesome, keep up the good work!

  26. 2 giugno 2013 alle 0:19

    You actually make it appear so easy with your presentation however I in finding this topic to be actually one thing
    which I believe I might by no means understand. It sort of feels too complicated and very huge for me.
    I’m taking a look forward to your next publish, I will try to get the grasp of it!

  27. 5 aprile 2014 alle 8:25

    Thank you for some other informative blog.

    The place else could I am getting that kind of info written in such an ideal approach?
    I’ve a venture that I am just now running on, and
    I have been at the glance out for such info.

  28. best skin care products for men
    5 settembre 2014 alle 17:55

    Howdy! I know this is kinda off topic but I’d figured I’d ask.
    Would you be interested in exchanging links or maybe guest authoring
    a blog article or vice-versa? My site goes over a lot of the same topics as yours
    and I feel we could greatly benefit from each other. If you might
    be interested feel free to shoot me an email. I look forward to hearing from you!

    Awesome blog by the way!

  29. 3 ottobre 2014 alle 4:02

    Hi there just wanted to give you a quick heads up and let you know a few of the images aren’t loading properly.
    I’m not sure why but I think its a linking issue. I’ve tried it in two different browsers and both show the
    same outcome.

  30. 15 ottobre 2014 alle 16:29

    My partner and I stumbled over here from a different web page and thought I might check things out.
    I like what I see so now i’m following you.
    Look forward to looking into your web page for a second time.

  31. 31 agosto 2016 alle 3:23

    It’s genuinely very complex in this full of activity life to listen news on TV, thus I just use
    the web for that reason, and get the newest information.

  1. 6 settembre 2014 alle 18:52

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: