Home > GNU/Linux > Call for test: per chi ha una scheda Intel o Ati con driver Open

Call for test: per chi ha una scheda Intel o Ati con driver Open

Chi ha una scheda grafica Intel (soprattutto se Sandy Bridge) o ATI ma con driver Open Source e usa Ubuntu 11.04, c’è un test per voi.

Prima di tutto aggiungete il mio repository “kernel and drivers”:

sudo apt-get install ppa-purge
sudo add-apt-repository ppa:guido-iodice/kernel-and-drivers
sudo apt-get update
sudo apt-get dist-upgrade

riavviate e controllate di stare usando il kernel 2.6.39-3 con

uname -r

Usate un po’ il computer su Internet (flash, video a schermo intero), testate applicazioni 3D (esempio: blender, Google Earth, qualche gioco se l’avete). Non dovreste avere problemi.

Questo repo contiene il kernel 2.6.39 nonché le versioni aggiornate dei driver Xorg.

Ora la cosa più importante, testiamo i nuovi driver 3D di Mesa. Aggiungete questo altro repo:

sudo add-apt-repository ppa:guido-iodice/testing3
sudo apt-get update
sudo apt-get dist-upgrade

riavviate e fate gli stessi test.

Chi ha una scheda Sandy Bridge o una ATI dovrebbe notare miglioramenti prestazionali (soprattutto nei giochi dove è facile vedere il FPS).

Fatemi sapere sia in positivo che negativo su questo topic, specificando l’hardware che usate.

Per rimettere tutto come prima:

sudo ppa-purge ppa:guido-iodice/testing3

ed eventualmente se volete rimuovere pure il primo repository:

sudo ppa-purge ppa:guido-iodice/kernel-and-drivers
Categorie:GNU/Linux Tag:,
  1. vittoria
    2 luglio 2011 alle 17:05

    ottimo! mi ha risolto un problema che avevo con Firefox: prima era tutto “verde” e le immagini apparivano in negativo ora pare tutto risolto!

  2. 3 luglio 2011 alle 15:25

    PRO:
    – la batteria dura leggermente di più,
    – video a schermo intero con plugin flash ora ok,
    – leggero incremento delle prestazioni con Unity.

    CONTRO:
    ancora da trovare

    Tutto ciò con una ATI Radeon HD 5470. A breve dovrei provare anche con il netbook con scheda grafica Intel: farò sapere al più presto😉

  3. robytrevi
    3 luglio 2011 alle 18:04

    Ati Xpress1100 vista come 200M da ubuntu
    Nessuna differenza apparente.

  4. 6 luglio 2011 alle 15:28

    Ciao Guiodic… Uso Ubuntu 11.04, ho aggiornato da qualche giorno il kernel alla vers. 3.00. La mia piattaforma hardware è: HP-Compaq NX7300 Celeron 1,73, 2GB ram, scheda grafica Intel GMA950 (lo so, roba obsoleta, ma questo passa il convento… ). I driver Mesa installati, come riportato dal software SecondLife (sono residente da quasi 4 anni), sono i 7.10.2 . Pensi che seguendo la seconda parte del tuo “test” otterrei miglioramenti nel 3D ? Cioè, i driver mesa che installerei sono migliori/più aggiornati ? SecondLife si trascina a stento, comunque molto meglio che con Windows… Anche una gestione energetica migliorata (post di Gianluca) non sarebbe male… Grazie

    • 6 luglio 2011 alle 18:33

      sì, dovresti provarlo. Anche se il kernel 3.0 io non lo userei onestamente, possono esserci incompatibilità con alcuni script e altro, e poi se non ricordo male non porta vantaggi sulla velocità grafica rispetto al 2.6.39

  5. 6 luglio 2011 alle 18:58

    Grazie🙂 Stasera provo. Complimenti per il tuo blog!

    • 7 luglio 2011 alle 20:37

      fammi sapere!

      • 13 luglio 2011 alle 19:04

        Ho finalmente provato i nuovi mesa… un disastro😦 Rallentamenti e colori falsati durante l’esecuzione di Second Life… li ho rimossi, tornando alla versione 7.10.2

        • 13 luglio 2011 alle 19:41

          con il kernel 3.0 o con il kernel 2.6.39?

          • 20 luglio 2011 alle 16:24

            Con il 2.6.39… ho preferito non usare il 3.0… scusa se passano giorni finché rispondo, è che ho diversi impegni in questo periodo. Spero che quanto sperimentato da me possa essere utile🙂 … Ciao

  6. giul
    7 luglio 2011 alle 21:20

    scheda grafica integrata nell’i3
    non sono un grande utilizzatore di prestazioni video ma comunque mi sembra vada meglio usando flash e google earth.

    ad ogni modo grazie per il lavoro

    • 8 luglio 2011 alle 12:41

      @giul: puoi dare per favore:

      glxinfo | grep vendor

      e

      lscpi | grep -i vga

      e copiare cosa esce?

      • giul
        16 luglio 2011 alle 10:48

        Ciao guido,

        riesco a risponderti dopo un bel po’, sempre ti serva ancora!

        allora:
        glxinfo | grep vendor

        Mesa: Initializing x86-64 optimizations
        server glx vendor string: SGI
        client glx vendor string: Mesa Project and SGI
        OpenGL vendor string: Tungsten Graphics, Inc

        lscpi invece mi dice non esiste….forse intendevi lspci?

        comunque lspci mi da’ questo:

        00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

        ..se era un altro comando fammi sapere

  7. 9 luglio 2011 alle 10:31

    Ciao volevo sapere se la guida in generale è utilizzabile su Kubuntu 11.04, e in particolare il repo: ppa:guido-iodice/kernel-and-drivers. Grazie.

  8. riccardo
    11 luglio 2011 alle 3:26

    migliorata la velocità : glxgears da 560 a 585
    hardware portatile hp nx9030 di 6 anni
    scheda video Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
    driver=i915 latency=0
    ciao
    rguanda

  9. 12 luglio 2011 alle 10:48

    Salve a tutti ho appena installato le PPA su un Lenovo Ideapad S205 piattaforma AMD Zacate.
    problemi riscontrati anche con questo kernel (presenti anche col kernel 2.6.38):
    Scheda WIFI Ralink rt30 non funziona. Ho provato a fare una ricerca google ma non riesco a venirne a capo. Il Netbook ha uno switch wireless che sembra essere il problema.

    Quando arresto o riavvio il netbook il procedimento si interrompe e devo spegnerlo a mano. qualcuno sa darmi una mano??

    grazie

    • Nicola
      12 luglio 2011 alle 11:23

      ho il tuo stesso portatile ed ho installato Ubuntu 11.04 64 bit

      per la wireless aggiungi questo alla fine in

      /etc/modprobe.d/blacklist.conf

      blacklist rt2800pci
      blacklist rt2800lib
      blacklist rt2800usb
      blacklist rt2x00pci
      blacklist rt2x00lib
      blacklist rt2x00usb
      blacklist acer_wmi

      e riavvia.

      Per il problema del riavvio vai nel Bios (F2) nella sezione Boot metti l’HDD sopra la voce ubuntu (premendo F6) salva ed esci poi:

      gksu gedit /etc/default/grub

      cambia
      GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”
      con
      GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash reboot=a,w”

      così funziona tutto.

      Io ho invece il problema che se provo ad installare il kernel 2.6.39 dal repo di guidoic mi propone di rimuovere Grub-efi-amd64 e di installare Grub-pc…solo che poi così facendo mi va in loop il bios… qualcuna sa se si può installare il kernel 2.6.39 mantenendo grub-efi?

      PS. grazie Guidoic uso i tuoi repo dalla 10.04😉

      • Nicola
        12 luglio 2011 alle 11:35

        dimenticavo dopo la modifica al Grub naturalmente bisogna dare:

        sudo update-grub

        Guido volevo chiederti anche se con questi nuovi driver Open per le schede video Radeon c’è la possibilità di sfruttare l’accellerazione hardware?

        • 12 luglio 2011 alle 12:31

          quale accelerazione hardware?

          • Nicola
            12 luglio 2011 alle 12:40

            si scusa tramite xvba, intendo l’accellerazione video

      • 13 luglio 2011 alle 10:18

        Ciao Nicola e grazie,

        avevo gia provato ad aggiungere quella stringa al suddetto file ma il wifi non andava. Ora va e te ne ringrazio. Quando ho fatto l’upgrade al kernel suggerito da Guido Grub-efi è stato sostituito da grub-pc ma nel mio caso non c’è un loop del bios (o almeno per l’utilizzo da me fatto non l’ho riscontrato.
        Ho cambiato la sequenza boot ed ora il pc termina la procedura di spegnimento e di riavvio. Non tutto va liscio perche comunque l’immagine di splash è distorta e scompare ppoco dopo facendo vedere il terminale e restano i cinque puntini ubuntu in sovraimpressione.

        Volevo chiederti altro: in skype il microfono non viene rilevato, hai lo stesso problema? leggevo in giro che anche lo slot SD non funziona. Veniva lamentato inoltre uno scarso transfer rate in modalità wifi che era aggirabile con l’installazione del seguente pacchetto:
        linux-backports-modules-headers-natty-generic-pae linux-backports-modules-net-natty-generic-pae

        va fatto anche su questo kernel?

        Grazie di nuovo,
        Davide

        • Nicola
          14 luglio 2011 alle 18:47

          Ciao, per il microfono e cuffie va aggiornato il modulo Alsa, puoi farlo tranquillamente tramite repository

          sudo add-apt-repository ppa:ubuntu-audio-dev/ppa

          il microfono funziona, non ho provato se funziona con skype ancora…

          per il wifi, per me non c’è bisogno di aggiungere quei pacchetti.

          lo slot sd non funziona purtroppo sia con Ubuntu 10.04 10.10 e 11.04.

          Per il bootloader la miglior cosa è quella di usare Grub Legacy non dà nessun problema.

          Ora finalmente ho trovato la giusta configurazione con la 10.04 a 32bit anche perchè con la 11.04 non c’è stato verso di far funzionare mplayer-vaapi per l’accelerazione dei video in hd…provato e riprovato più volte ma niente.

          Spero che la prossima 11.10 sia migliore, altrimenti rimango fino al 2013 con la 10.04😀

  10. 13 luglio 2011 alle 16:07

    quale accelerazione hardware?

    Nicola :

    si scusa tramite xvba, intendo l’accellerazione video

    Non credo funzioni.

    • 30 luglio 2011 alle 10:12

      Ciao Nicola,

      ho dovuto formattare Ubuntu e reinstallarlo e grub2 mi incasina tutto.

      La ISO original di ubuntu ha il kernel 2.6.38-8 ed il bootloader installato di default è grub-efi. All’avanzamento di versione che viene richiesta subito dopo l’installazione del SO grub-efi viene sostituito da grub-pc ed iniziano i dolori. ubuntu non si riavvia piu ed il BIOS va in loop.

      ho provato a bloccare i pacchetti di grub-efi ma l’avanzamento ha installato grub-pc ed immagino che al riavvio il pc non partirà come ho gia verificato diverse volte ormai.

      Sai darmi una mano su come riuscire a venirne a capo? Il problema è di natura hardware (linux non riconosce questa piattaforma?). Installare il kernel 3.0-3 attualmente usato da Oneiric risolve i problemi?

  11. 18 luglio 2011 alle 14:01

    Da quando ho installato la 11.04 sul netbook ho problemi di surriscaldamento, non eccessivo ma fastidioso. provo a metterli

    • 18 luglio 2011 alle 14:18

      GRAZIE….
      netbook Asus eeePC 904HD… il netbook si sta raffreddando

    • 1 agosto 2011 alle 1:10

      complimenti per la guida, l’ho seguita passo passo e le cose sembrano funzionare meglio. Ti volevo chiedere una cosa riguardo i driver ATI. ho installato quelli consigliati da te, il procedimento va a buon fine ma è come se i driver non siano installati. il driver manager continua a chiedermi di installare i driver proprietari che sono di una versione precedente. Dov’è il problema?

      Grazie ancora,
      Davide

      • Nicola
        1 agosto 2011 alle 8:50

        se da terminale dai fglrxinfo e come risultato hai questo:

        display: :0 screen: 0
        OpenGL vendor string: ATI Technologies Inc.
        OpenGL renderer string: AMD Radeon HD 6300 series Graphics
        OpenGL version string: 4.1.10907 Compatibility Profile Context

        e poi per verificare l’accelerazione 3D :

        glxinfo | grep render

        se hai un risultato così

        direct rendering: Yes
        OpenGL renderer string: AMD Radeon HD 6300 series Graphics
        GL_NV_conditional_render, GL_NV_copy_depth_to_color,

        allora è tutto ok. L’importante e non installare i driver che ti propone Ubuntu perchè sono più vecchi.

      • 1 agosto 2011 alle 23:02

        questi sono i driver open source, meno male che l’ho scritto tre volte!

        • Nicola
          2 agosto 2011 alle 9:15

          Lo so che sono Open Source, ma io mi riferivo ad altro…eravamo off topic scusa.😉

  12. 18 luglio 2011 alle 14:19

    Sei su g+?

  13. hug
    18 luglio 2011 alle 19:34

    O.T.
    Mi è appena arrivata la mail di LQH che avvisa della chiusura del sito.
    Mi spiace molto. Mi avete aiutato tante volte ed era per me un punto di riferimento.
    Un abbraccio.

  14. Paul
    18 luglio 2011 alle 22:24

    Ciao,

    ho avuto un messaggio del tipo

    blcr (0.8.2)…failed

    installando il kernel 2.6.39-3. In realtà mi è successo anche in precedenza con il 3.0.0-rc7.

    Sai spiegarmi le implicazione di un simile “fail” ?

    grazie,
    Paul

  15. Diego
    26 luglio 2011 alle 13:21

    Ciao Guido… a quando il kernel 3.0?

  16. 30 luglio 2011 alle 4:46

    Ciao guido li ho provati per un pò, ma non ho notato miglioramenti, anzi proprio oggi firefox si è imballato 2 volte con applicazioni flash, dandomi solo la possibilità di muovere il mouse e di andare in shell. Alt+f2 non andava! ho rimesso tutto a posto, poi ti dirò se ho gli stessi problemi o se sono scomparsi…

    Uso una ati HD3650

  17. 20 maggio 2014 alle 5:26

    Please let me know if you’re looking for a article writer for
    your site. You have some really great articles and I think I would be a good asset.

    If you ever want to take some of the load off, I’d absolutely love to write some articles for your blog in exchange for a link back to mine.
    Please blast me an e-mail if interested. Thank you!

  1. No trackbacks yet.

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: